xfs
[Top] [All Lists]

Re: [PATCH 08/18] xfs: rename xfs_buf_get_nodaddr to be more appropriate

To: Dave Chinner <david@xxxxxxxxxxxxx>
Subject: Re: [PATCH 08/18] xfs: rename xfs_buf_get_nodaddr to be more appropriate
From: Alex Elder <aelder@xxxxxxx>
Date: Tue, 14 Sep 2010 17:14:18 -0500
Cc: xfs@xxxxxxxxxxx
In-reply-to: <1284461777-1496-9-git-send-email-david@xxxxxxxxxxxxx>
References: <1284461777-1496-1-git-send-email-david@xxxxxxxxxxxxx> <1284461777-1496-9-git-send-email-david@xxxxxxxxxxxxx>
Reply-to: aelder@xxxxxxx
On Tue, 2010-09-14 at 20:56 +1000, Dave Chinner wrote:
> From: Dave Chinner <dchinner@xxxxxxxxxx>
> 
> xfs_buf_get_nodaddr() is really used to allocate a buffer that is
> uncached. While it is not directly assigned a disk address, the fact
> that they are not cached is a more important distinction. With the
> upcoming uncached buffer read primitive, we should be consistent
> with this disctinction.
> 
> While there, make page allocation in xfs_buf_get_nodaddr() safe
> against memory reclaim re-entrancy into the filesystem by changing
> the allocation to GFP_NOFS.

This could be spun into its own patch (#19 or more).  But
I don't think it's that important.

> 
> Signed-off-by: Dave Chinner <dchinner@xxxxxxxxxx>
> ---
>  fs/xfs/linux-2.6/xfs_buf.c   |    6 +++---
>  fs/xfs/linux-2.6/xfs_buf.h   |    2 +-

Looks good.

Reviewed-by: Alex Elder <aelder@xxxxxxx>


<Prev in Thread] Current Thread [Next in Thread>