xfs
[Top] [All Lists]

Re: [PATCH 08/18] xfs: rename xfs_buf_get_nodaddr to be more appropriate

To: Dave Chinner <david@xxxxxxxxxxxxx>
Subject: Re: [PATCH 08/18] xfs: rename xfs_buf_get_nodaddr to be more appropriate
From: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date: Tue, 14 Sep 2010 10:56:17 -0400
Cc: xfs@xxxxxxxxxxx
In-reply-to: <1284461777-1496-9-git-send-email-david@xxxxxxxxxxxxx>
References: <1284461777-1496-1-git-send-email-david@xxxxxxxxxxxxx> <1284461777-1496-9-git-send-email-david@xxxxxxxxxxxxx>
User-agent: Mutt/1.5.20 (2009-08-17)
>  xfs_buf_t *
> -xfs_buf_get_noaddr(
> +xfs_buf_get_uncached(
>       size_t                  len,
>       xfs_buftarg_t           *target)
>  {
> @@ -725,7 +725,7 @@ xfs_buf_get_noaddr(
>               goto fail_free_buf;
>  
>       for (i = 0; i < page_count; i++) {
> -             bp->b_pages[i] = alloc_page(GFP_KERNEL);
> +             bp->b_pages[i] = alloc_page(GFP_NOFS);

Instead of doingthis unconditionally I think it's better to add a flags
aregument which can contain XBF_DONT_BLOCK, and then use xb_to_gfp for
the flags.

<Prev in Thread] Current Thread [Next in Thread>