xfs
[Top] [All Lists]

logerrors on armv5te hardware rendering xfs-partition unmountable

To: xfs@xxxxxxxxxxx
Subject: logerrors on armv5te hardware rendering xfs-partition unmountable
From: Marcus Osdoba <marcus.osdoba@xxxxxxxxxxxxxx>
Date: Thu, 09 Sep 2010 20:40:50 +0200
Cc: Dave Chinner <david@xxxxxxxxxxxxx>, Eric Sandeen <sandeen@xxxxxxxxxxx>
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=googlemail.com; s=gamma; h=domainkey-signature:received:received:message-id:date:from :user-agent:mime-version:to:cc:subject:content-type :content-transfer-encoding; bh=+yVK2RfadpjLyISms9RQrOcKO+tJ/RsQa9YsUiD70OA=; b=TquKZdA78C//L4ACbA6JIIraccDPw6LiWIgoiV+mJSKIrGk0yV2nEh9c1IYGWnbxpw i4+9/llrEauIH8g2coEOZ0gfGj7o+iwVWOu/OgyJ7lkFFomk54UGZdtDoGxo+HnR28Ep XCwtQ0WauNZ5n2As++mW7Uchgj4raVZtIPaOQ=
Domainkey-signature: a=rsa-sha1; c=nofws; d=googlemail.com; s=gamma; h=message-id:date:from:user-agent:mime-version:to:cc:subject :content-type:content-transfer-encoding; b=TL3+kcfXx1A0tTifQ2NcxEkfK6WWmiA9TKyBznFsGoa0IStHpJBiGh+//DQNOt1r/y 74qUn9inDr/jo71HQyN3ftnOwO7WCab97+3x1CWreZ/kvkqzsqN7pd6tyDbhb/NTRk+X 9NP6MbdyEN1KmP9BhT6RvN1asbPBm9Ij7Wzmo=
User-agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.9) Gecko/20100825 Thunderbird/3.1.3
 Dear mailinglist,

I run a kernel 2.6.35.4 on my SeagateDockStar which is based on the sheevaplug (kirkwood armv5te). Once searching the archive of the this mailinglist, I figured out, that there problems in the past with running xfs on CPUs with virtually indexed caches (like arm). A series of patches was applied in Febuary 2010 with the purpose to resolve the problems on arm devices.

With the recent linux kernel I'm using, I still discover errors. I was forced to run xfs_repair -l /dev/sdx1 before I could mount the partition again. I was asked by one of the respectable mailinglist members to give the complete output of the commands I launched.

Please find below the hardcopy of my terminal output and let me know, what debug information do you need and how (and when) this must be obtained.

Thank you and kind regards,
Marcus

$ mkfs.xfs -f /dev/sda1
meta-data=/dev/sda1 isize=256 agcount=4, agsize=19535620 blks
         =                       sectsz=512   attr=2
data     =                       bsize=4096   blocks=78142479, imaxpct=25
         =                       sunit=0      swidth=0 blks
naming   =version 2              bsize=4096   ascii-ci=0
log      =internal log           bsize=4096   blocks=38155, version=2
         =                       sectsz=512   sunit=0 blks, lazy-count=1
realtime =none                   extsz=4096   blocks=0, rtextents=0
$ mount -t xfs /dev/sda1 /data
$ dmesg|tail
sd 0:0:0:0: [sda] Assuming drive cache: write through
sd 0:0:0:0: [sda] Attached SCSI disk
SGI XFS with ACLs, security attributes, large block/inode numbers, no debug enabled
SGI XFS Quota Management subsystem
XFS mounting filesystem sda1
Ending clean XFS mount for filesystem: sda1
$ cp /bin/* /data
$ umount /data
$ xfs_logprint /dev/sda1|tail
----------------------------------------------------------------------------
Oper (0): tid: 22e742e6  len: 4  clientid: TRANS  flags: WAS_CONT END
Left over region from split log item
----------------------------------------------------------------------------
Oper (1): tid: 22e742e6  len: 512  clientid: TRANS  flags: none
Left over region from split log item
----------------------------------------------------------------------------
Oper (2): tid: 22e742e6  len: 256  clientid: TRANS  flags: none
xfs_logprint: unknown log operation type (e3cf)
**********************************************************************
* ERROR: data block=66                                                *
**********************************************************************
Bad data in log
$ mount -t xfs /dev/sda1 /data
$ dmesg|tail
SGI XFS with ACLs, security attributes, large block/inode numbers, no debug enabled
SGI XFS Quota Management subsystem
XFS mounting filesystem sda1
Ending clean XFS mount for filesystem: sda1
XFS mounting filesystem sda1
Ending clean XFS mount for filesystem: sda1
XFS mounting filesystem sda1
Ending clean XFS mount for filesystem: sda1
XFS mounting filesystem sda1
Ending clean XFS mount for filesystem: sda1
$ mkdir /data/usr;cp -r /usr /data/usr
$ umount /data
$ xfs_logprint /dev/sda1|tail
xfs_logprint: unknown log operation type (e3cf)
Bad data in log
Oper (0): tid: 22e742e6  len: 4  clientid: TRANS  flags: WAS_CONT END
Left over region from split log item
----------------------------------------------------------------------------
Oper (1): tid: 22e742e6  len: 512  clientid: TRANS  flags: none
Left over region from split log item
----------------------------------------------------------------------------
Oper (2): tid: 22e742e6  len: 256  clientid: TRANS  flags: none
**********************************************************************
* ERROR: data block=66                                                *
**********************************************************************
$ mount -t xfs /dev/sda1 /data
mount: mounting /dev/sda1 on /data failed: Input/output error
$ dmesg|tail
Ending clean XFS mount for filesystem: sda1
XFS mounting filesystem sda1
Ending clean XFS mount for filesystem: sda1
XFS mounting filesystem sda1
Starting XFS recovery on filesystem: sda1 (logdev: internal)
XFS: xlog_recover_process_data: bad clientid
XFS: log mount/recovery failed: error 5
XFS: log mount failed
$


<Prev in Thread] Current Thread [Next in Thread>