xfs
[Top] [All Lists]

Re: filesystem shrinks after using xfs_repair

To: Dave Chinner <david@xxxxxxxxxxxxx>
Subject: Re: filesystem shrinks after using xfs_repair
From: Eli Morris <ermorris@xxxxxxxx>
Date: Thu, 29 Jul 2010 16:15:55 -0700
Cc: xfs@xxxxxxxxxxx, Emmanuel Florac <eflorac@xxxxxxxxxxxxxx>
In-reply-to: <20100729230147.GN655@dastard>
References: <F2AC32C3-2437-4625-980A-3BC9B3C541A2@xxxxxxxx> <20100724023922.GP32635@dastard> <777100A1-57DE-4DE0-B1F0-64977BD694AD@xxxxxxxx> <20100726034545.GE655@dastard> <10B6F36F-BE01-4BF7-9815-2E8F6BF71B41@xxxxxxxx> <20100726060604.GF7362@dastard> <F91DF703-4BFF-415B-91B6-87A88F096C91@xxxxxxxx> <20100726102036.GH7362@dastard> <0EC8FE5D-212C-4030-9D59-FDF38DF4E9EE@xxxxxxxx> <D6C570D6-FEC7-4E3C-AAC2-13275721370A@xxxxxxxx> <20100729230147.GN655@dastard>
On Jul 29, 2010, at 4:01 PM, Dave Chinner wrote:

> On Thu, Jul 29, 2010 at 12:22:30PM -0700, Eli Morris wrote:
>> I tried filling up the disk with data to see if that worked Ok and
>> it did, up until this point. There is something I don't understand
>> going on though. 'df' says that I have 381 GB free on the disk,
>> but I can't write to the disk anymore because it says it there
>> isn't any space left on it. Is this some insane round off error or
>> is there something going on here?
> 
> If you haven't specified inode64, then all inodes are located below
> the 1TB mark. You've probably run out of space (or contiguous 16k
> chunks of free space) below 1TB. Using inode64 will avoid this - for
> a filesystem of that size, inode64 is probably a good idea as it
> will significantly improve performance.
> 
> Keep in mind that legacy 32bit applications may have problems with
> 64 bit inode numbers, so if you have such applications (or 32 bit
> NFS clients) then you need to check carefully as to whether 64 bit
> inodes will work correctly or not....
> 
> Cheers,
> 
> Dave.
> -- 
> Dave Chinner
> david@xxxxxxxxxxxxx


Hi Dave,

Is that something I could do now, or only when the filesystem is created? If I 
mount it with '-o inode64', can I mount it without that later, or once I write 
to the filesystem like that, can I not go back to mounting it in 32 bit mode? 

Thanks again,

Eli



<Prev in Thread] Current Thread [Next in Thread>