xfs
[Top] [All Lists]

Re: [PATCH 3/4] xfs: rename XFS_IGET_BULKSTAT to XFS_IGET_UNTRUSTED

To: Dave Chinner <david@xxxxxxxxxxxxx>
Subject: Re: [PATCH 3/4] xfs: rename XFS_IGET_BULKSTAT to XFS_IGET_UNTRUSTED
From: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date: Mon, 21 Jun 2010 03:21:59 -0400
Cc: xfs@xxxxxxxxxxx, security@xxxxxxxxxx
In-reply-to: <1277078341-19087-4-git-send-email-david@xxxxxxxxxxxxx>
References: <1277078341-19087-1-git-send-email-david@xxxxxxxxxxxxx> <1277078341-19087-4-git-send-email-david@xxxxxxxxxxxxx>
User-agent: Mutt/1.5.20 (2009-08-17)
On Mon, Jun 21, 2010 at 09:59:00AM +1000, Dave Chinner wrote:
> From: Dave Chinner <dchinner@xxxxxxxxxx>
> 
> Inode numbers may come from somewhere external to the filesystem
> (e.g. file handles, bulkstat information) and so are inherently
> untrusted. Rename the flag we use for these lookups to make it
> obvious we are doing a lookup of an untrusted inode number and need
> to verify it completely before trying to read it from disk.
> 
> Signed-off-by: Dave Chinner <dchinner@xxxxxxxxxx>

Looks good,


Reviewed-by: Christoph Hellwig <hch@xxxxxx>

<Prev in Thread] Current Thread [Next in Thread>