xfs
[Top] [All Lists]

segment fault when running xfs_check -s

To: xfs@xxxxxxxxxxx
Subject: segment fault when running xfs_check -s
From: xiaowei hu <xiaowei.hu@xxxxxxxxxx>
Date: Mon, 21 Jun 2010 10:55:18 +0800
Cc: wen.gang.wang@xxxxxxxxxx
Organization: Oracle
Reply-to: xiaowei.hu@xxxxxxxxxx
Hi,

Recently I was playing with xfsprogs, and did some test on xfs_check
tools in this mothod:
1.make a xfs fs on one partition.
mkfs.xfs -f /dev/sda2
2.randomly modify some blocks on this volume using xfs_db.
xfs_db -x -c blockget -c "blocktrash -3 -s 36 -n 81" /dev/sda2
3.run xfs_check -s
xfs_check -s /dev/sda2

the output saying:
[root@test1 ~]# xfs_check -s /dev/sda2
bad version number 0x78 for inode 135
bad magic number 0xa855 for inode 154
bad magic number 0x5024 for inode 165
/usr/local/bin/xfs_check: line 28:   769 Segmentation fault      xfs_db
$DBOPTS -F -i -p xfs_check -c "blockget$OPTS" $1

if I run xfs_check without -s option, don't have this fault.

Is this a known problem?

I tried the latest code ,also have this problem.


thanks,
Xiaowei



<Prev in Thread] Current Thread [Next in Thread>