xfs
[Top] [All Lists]

Re: xfs_repair 3.1.2 crashing

To: xfs@xxxxxxxxxxx
Subject: Re: xfs_repair 3.1.2 crashing
From: Michael Monnerie <michael.monnerie@xxxxxxxxxxxxxxxxxxx>
Date: Mon, 14 Jun 2010 14:47:57 +0200
In-reply-to: <201006121533.36684@xxxxxx>
Organization: it-management http://it-management.at
References: <201006101306.07587@xxxxxx> <4C12E520.6040008@xxxxxxxxxxx> <201006121533.36684@xxxxxx>
User-agent: KMail/1.12.4 (Linux/2.6.31.12-0.2-desktop; KDE/4.3.5; x86_64; ; )
On Samstag, 12. Juni 2010 Michael Monnerie wrote:
> [167981.222861]  [<ffffffff8000c868>]
>  system_call_fastpath+0x16/0x1b                                      

Now it's becoming weird. I had that crash with a directory named
/disks/daten/samba/backup/uranus/WindowsImageBackup/uranus/Backup\ 
2010-06-12\ 010016/ /bigbackup/Backup\ 2010-06-05\ 010014/
and the file in there is
852c2690-cf1a-11de-b09b-806e6f6e6963.vhd

I moved that broken dir away to /, and did a new rsync. And, guess what, 
I got the same again: the file inside this dir is broken. The 3rd rsync 
did not make the same error, it seems good. The problem is that the dump 
is not the same any more, as that PC made a new image in the meantime. 
But as I got the same error twice on copy via rsync from one PC to 
another, it looks like I triggered the error just by copying via "rsync 
-aPvHAXy source destpc::dest/".

I did an xfs_metadump and just left the 2 broken dirs inside, so you can 
easily verify:
http://zmi.at/backup-metadump-20100614-broken.bz2

xfs_repair 3.1.2 can't repair that, it crashes.

The filesystem is mounted with these options:
relatime,logbufs=8,logbsize=256k,attr2,barrier,largeio,swalloc,allocsize=256k

-- 
mit freundlichen Grüssen,
Michael Monnerie, Ing. BSc

it-management Internet Services
http://proteger.at [gesprochen: Prot-e-schee]
Tel: 0660 / 415 65 31

// Wir haben im Moment zwei Häuser zu verkaufen:
// http://zmi.at/langegg/
// http://zmi.at/haus2009/

Attachment: signature.asc
Description: This is a digitally signed message part.

<Prev in Thread] Current Thread [Next in Thread>