xfs
[Top] [All Lists]

Structure needs cleaning - Seagate Expansion External HDD 2TB USB

To: xfs@xxxxxxxxxxx
Subject: Structure needs cleaning - Seagate Expansion External HDD 2TB USB
From: Marcel z maleho mesta <newsx@xxxxxxxxxxxxxx>
Date: Sat, 15 May 2010 23:07:16 +0100
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9) Gecko/20100317 SeaMonkey/2.0.4
Hi all,

I'm new to Linux (still got Win XP running on my laptops :(, but installed on my old machine Fedora 12, which looks really good :)

I have got a problem with my external Seagate Expansion External HDD 2TB USB drive which has been connected to my NAS Bufallo LinkStation Mini.

I did have to disconnect the USB drive from NAS one day and since then it would not be recognised by NAS. So have tried some Win tools, but the USB drive has got XFS file system.

When I plug it to pc running Fedora 12, Palimpsest Disk Utility see the Hard Drive, but when I attempt to Mount the drive Error mounting device - Unknown error msg. comes up.
Details:
Error mounting: mount: Structure needs cleaning.

Have googled it: http://xfs.org/index.php/XFS_FAQ#Q:_I_see_applications_returning_error_990_or_.22Structure_needs_cleaning.22.2C_what_is_wrong.3F and tried xfs_repair /dev/sdb1 and xfs_check /dev/sdb1 and can Mount the disk and all the folders in root apart from few files are ok "copied into Lost+Found Folder", but the most important one "DVBgrab" with about 400Gb of data :( (each file is between 1 and 2 Gb) is missing.

Are those files gone, or is there a chance that they can be somehow recovered with combination of xfs_repair commands?


Thanx in advance.

Marcel

<Prev in Thread] Current Thread [Next in Thread>