xfs
[Top] [All Lists]

Re: bad primary superblock - bad magic number !!!

To: Emmanuel Florac <eflorac@xxxxxxxxxxxxxx>
Subject: Re: bad primary superblock - bad magic number !!!
From: Leo Davis <leo1783@xxxxxxxxx>
Date: Wed, 12 May 2010 02:19:16 -0700 (PDT)
Cc: xfs@xxxxxxxxxxx
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=yahoo.com; s=s1024; t=1273655957; bh=2E3JEeYCcYorC19p7n4nSH/Ufu3jNNxpnVRzj4rdQ6E=; h=Message-ID:X-YMail-OSG:Received:X-Mailer:References:Date:From:Subject:To:Cc:In-Reply-To:MIME-Version:Content-Type; b=wHCYn5sxlDxy0llP4sXBIt/P/ke2Ki/PEyxJid6wN/FERsxiZOJpDQ1eZKi8j3ohKmZG8gjaG5qGlJJP0PLYh3egITFtnxWyr849Hyq+s7ozkFkZP8Sjv7agvTOsMc4oA74UhA4HFjL1wlGGo+6cUHp8G5BC+YPcj5fmhZIEq2c=
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.com; h=Message-ID:X-YMail-OSG:Received:X-Mailer:References:Date:From:Subject:To:Cc:In-Reply-To:MIME-Version:Content-Type; b=ED7vHNFzeLT32e5Ad+1L6aloEERP+0pu6STtIh2O7tEVuWkpR7L90hQuLEbrWTvnpu/KUCCR1TSSntwNya6uZjPSG6qQMab0Z55vXTfZPEFjfxy8b+7SSd1QqzdUipTvZ3X5eGDAeM459EsePgcayCO10u4690p+yZvrF2Np8Q8=;
In-reply-to: <20100510222211.3e73cdeb@xxxxxxxxxxxxxx>
References: <28512276.post@xxxxxxxxxxxxxxx> <4BE82955.2080009@xxxxxxxxxxx> <978493.86662.qm@xxxxxxxxxxxxxxxxxxxxxxxxxxxx> <20100510222211.3e73cdeb@xxxxxxxxxxxxxx>
havent had much success with testing the hard drives, tried mhdd & seatools with no luck yet.

Meanwhile i recreated RAID, all shows up OK for now.

Previously the msgs shown were:

end_request: I/O error, dev cciss/c0d2, sector 0
end_request: I/O error, dev cciss/c0d2, sector 0
end_request: I/O error, dev cciss/c0d2, sector 1

That seems to indicate that the problem is with the disc or array. It is unable to read the beginning of the device.
So is I do a - dd if=/dev/random of=dev/cciss/c0d2 , that should fail and therby confirm that the drive or array has issues...do i make any sense here?

thanks




From: Emmanuel Florac <eflorac@xxxxxxxxxxxxxx>
To: Leo Davis <leo1783@xxxxxxxxx>
Cc: xfs@xxxxxxxxxxx
Sent: Mon, May 10, 2010 9:22:11 PM
Subject: Re: bad primary superblock - bad magic number !!!

Le Mon, 10 May 2010 11:11:45 -0700 (PDT) vous écriviez:

> I agree. I destroy and re-create raid and everything would show up
> GOOD, only for it to break again. So was wondering whether those
> traces would point to anything.... my prime suspect is hard drives,
> but those xfs msgs confused me.

Check the hard drives separately with the maker utility (Seatools,
etc). One of them at the very least must be seriously ill.

--
------------------------------------------------------------------------
Emmanuel Florac    |  Direction technique
                    |  Intellique
                    |    <eflorac@xxxxxxxxxxxxxx>
                    |  +33 1 78 94 84 02
------------------------------------------------------------------------

<Prev in Thread] Current Thread [Next in Thread>