xfs
[Top] [All Lists]

Re: failed to read root inode

To: xfs@xxxxxxxxxxx
Subject: Re: failed to read root inode
From: Christian Affolter <christian.affolter@xxxxxxxxxxxxx>
Date: Sun, 09 May 2010 16:53:00 +0200
In-reply-to: <4BE57E0D.3020601@xxxxxxxxxxx>
References: <4BE55A63.8070203@xxxxxxxxxxxxx> <4BE57E0D.3020601@xxxxxxxxxxx>
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9) Gecko/20100420 Thunderbird/3.0.4
Hi Eric

Thanks for your answer.

>> After a disk crash within a hardware RAID-6 controller and kernel
>> freeze, I'm unable to mount an XFS filesystem on top of an EVMS volume:
> 
> Are you sure the volume is reassembled correctly?  It seems like the
> fs has a ton of damage ...
> 
> One trick I often recommend is to make a metadata image of the fs
> with xfs_metadump / xfs_mdrestore and run repair on that to see
> what repair -would- do, but I guess you've already run it on the
> real fs.

OK, I didn't know that. I actually cloned the faild volume using dd and
run xfs_repair on the clone.


> So if repair isn't making a mountable fs, first suggestion would
> be to re-try with the latest version of repair.

OK, I will try that. Unfortunately the latest upstream version isn't
included within the distribution package repository, so I will have to
compile it first.


>> Filesystem "dm-13": Disabling barriers, not supported by the underlying
>> device
> 
> Honestly, that could be part of the problem too, if a bunch of
> disks with write caches all lost them, in the array.
> 
>> XFS mounting filesystem dm-13
>> Starting XFS recovery on filesystem: dm-13 (logdev: internal)
>> XFS internal error XFS_WANT_CORRUPTED_GOTO at line 1599 of file
>> fs/xfs/xfs_alloc.c.  Caller 0xffffffff8035c58d
>> Pid: 13473, comm: mount Not tainted 2.6.26-gentoo #1
> ...
> 
>> XFS: log mount finish failed
> 
> So recovery is failing, you could try mount -o ro,norecovery at this
> point to see what's still left on the fs... but:

This didn't made any difference, I'm still getting the same error message.


>> I tried to repair the filesystem with the help of xfs_repair many times,
>> without any luck:
>> Filesystem "dm-13": Disabling barriers, not supported by the underlying
>> device
>> XFS mounting filesystem dm-13
>> XFS: failed to read root inode
> 
> ...
> 
>> xfs_check output:
>> cache_node_purge: refcount was 1, not zero (node=0x820010)
>> xfs_check: cannot read root inode (117)
> 
> That's a bit of an odd root inode number, I think, which
> makes me think maybe there are still serious problems.
> 
>> Are there any other ways to fix the unreadable root inode or to restore
>> the remaining data?
>>
>>
>> Environment informations:
>> Linux Kernel: 2.6.26-gentoo (x86_64)
>> xfsprogs:     3.0.3
> 
> Those are both pretty old at this point, I can't say there is anything
> specific in newer xfsprogs, but I'd probably give that a shot first.

Yes I'm going to try the latest version.


Thanks
Christian

<Prev in Thread] Current Thread [Next in Thread>