xfs
[Top] [All Lists]

Re: [PATCH] xfstests: made test 215 backwards compatible with older vers

To: Akshay Lal <akshaylal@xxxxxxxxxx>
Subject: Re: [PATCH] xfstests: made test 215 backwards compatible with older version of bash.
From: Dave Chinner <david@xxxxxxxxxxxxx>
Date: Thu, 1 Apr 2010 09:33:21 +1100
Cc: xfs@xxxxxxxxxxx
In-reply-to: <1270062393-5233-1-git-send-email-akshaylal@xxxxxxxxxx>
References: <1270062393-5233-1-git-send-email-akshaylal@xxxxxxxxxx>
User-agent: Mutt/1.5.20 (2009-06-14)
On Wed, Mar 31, 2010 at 12:06:33PM -0700, Akshay Lal wrote:
> Test 215 fails on older versions of bash (2.x), mainly due to the use of
> 'let' for arithemetic operations. Changed to 'expr'.

If that is a problem for older bash versions, then there's going
systemic problems throughout the xfstests suite. The let expression
is used about 80 different places, and I don't see anything special
about test 215 that makes it any different from other uses. i might
be missing something, but there's not much context to go on from
your changelog....

Perhaps upgrading your version of bash might be a better approach?

Cheers,

Dave.
-- 
Dave Chinner
david@xxxxxxxxxxxxx

<Prev in Thread] Current Thread [Next in Thread>