On Wed, Jan 27, 2010 at 05:14:54PM -0600, Eric Sandeen wrote:
> This mangles the reserved blocks counts a little more.
> 1) add a helper function for the default reserved count
> 2) add helper functions to save/restore counts on ro/rw
> 3) save/restore reserved blocks on freeze/thaw
> 4) disallow changing reserved count while readonly
> for 2) - maybe better names (save_and_clear?)
> for 4) - maybe allow, but change the _ro field instead?
> (TBH not tested yet but wondered if this seems sane)
I was wondering if the save/restore could be encapsualted entirely
within xfs_quiesce_attr(). i.e. save before the superblock write,
restore directly after. That removes the need for a variable in
the xfs_mount structure, and catches both remount,ro and freeze.
What do you think?