xfs
[Top] [All Lists]

RE: [PATCH 3/3] xfs: clean up inconsistent variable naming inxfs_swap_ex

To: "Dave Chinner" <david@xxxxxxxxxxxxx>
Subject: RE: [PATCH 3/3] xfs: clean up inconsistent variable naming inxfs_swap_extent
From: "Alex Elder" <aelder@xxxxxxx>
Date: Thu, 14 Jan 2010 09:41:48 -0600
Cc: <xfs@xxxxxxxxxxx>
In-reply-to: <1263432836-13368-4-git-send-email-david@xxxxxxxxxxxxx>
Thread-index: AcqUvh7IQRsmtRvZTNWXWR2WEMtbbAAceBng
Thread-topic: [PATCH 3/3] xfs: clean up inconsistent variable naming inxfs_swap_extent
Dave Chinner wrote:
> The swap extent ioctl passes in a target inode and a temporary
> inode which are clearly named in the ioctl structure. The code
> then assigns temp to target and vice versa, making it extremely
> difficult to work out which inode is which later in the code.
> Make this consistent throughout the code.
> 
> Also make xfs_swap_extent static as there are no external users
> of the function.

All three patches in this series look good.

> Signed-off-by: Dave Chinner <david@xxxxxxxxxxxxx>

Reviewed-by: Alex Elder <aelder@xxxxxxx>

...

<Prev in Thread] Current Thread [Next in Thread>