[Top] [All Lists]

Re: [PATCH 1/6] [XFS] rename xfs_get_perag

To: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Subject: Re: [PATCH 1/6] [XFS] rename xfs_get_perag
From: Dave Chinner <david@xxxxxxxxxxxxx>
Date: Fri, 11 Dec 2009 10:25:29 +1100
Cc: xfs@xxxxxxxxxxx
In-reply-to: <20091210231511.GA6389@xxxxxxxxxxxxx>
References: <1259734299-20306-1-git-send-email-david@xxxxxxxxxxxxx> <1259734299-20306-2-git-send-email-david@xxxxxxxxxxxxx> <20091210231511.GA6389@xxxxxxxxxxxxx>
User-agent: Mutt/1.5.18 (2008-05-17)
On Thu, Dec 10, 2009 at 06:15:11PM -0500, Christoph Hellwig wrote:
> On Wed, Dec 02, 2009 at 05:11:34PM +1100, Dave Chinner wrote:
> > xfs_get_perag is really getting the perag that an inode
> > belongs to based on it's inode number. Rename it appropriately
> > so we can use xfs_perag_get() to get the perag from a
> > provided ag number.
> It does quite a bit more than the description suggests.  I also uses the
> new xfs_get_perag in some places and passes the perag around a bit more.

True - the patch grew beyond it's initial description...

> Might be worth splitting or at least needs a better description.

Better description. ;)

> Also I'm not sure the new xfs_perag_get_from_ino is actually all that useful,
> opencoding it is more descriptive and barely longer.

Ok, I'll redo it and open code all these as well.


Dave Chinner

<Prev in Thread] Current Thread [Next in Thread>