[Top] [All Lists]

Re: [PATCH 1/6] [XFS] rename xfs_get_perag

To: Dave Chinner <david@xxxxxxxxxxxxx>
Subject: Re: [PATCH 1/6] [XFS] rename xfs_get_perag
From: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date: Thu, 10 Dec 2009 18:15:11 -0500
Cc: xfs@xxxxxxxxxxx
In-reply-to: <1259734299-20306-2-git-send-email-david@xxxxxxxxxxxxx>
References: <1259734299-20306-1-git-send-email-david@xxxxxxxxxxxxx> <1259734299-20306-2-git-send-email-david@xxxxxxxxxxxxx>
User-agent: Mutt/1.5.19 (2009-01-05)
On Wed, Dec 02, 2009 at 05:11:34PM +1100, Dave Chinner wrote:
> xfs_get_perag is really getting the perag that an inode
> belongs to based on it's inode number. Rename it appropriately
> so we can use xfs_perag_get() to get the perag from a
> provided ag number.

It does quite a bit more than the description suggests.  I also uses the
new xfs_get_perag in some places and passes the perag around a bit more.

Might be worth splitting or at least needs a better description.

Also I'm not sure the new xfs_perag_get_from_ino is actually all that useful,
opencoding it is more descriptive and barely longer.

<Prev in Thread] Current Thread [Next in Thread>