xfs
[Top] [All Lists]

Re: can't mount XFS from a read-only device

To: Emmanuel Florac <eflorac@xxxxxxxxxxxxxx>
Subject: Re: can't mount XFS from a read-only device
From: Eric Sandeen <sandeen@xxxxxxxxxxx>
Date: Fri, 09 Oct 2009 14:28:47 -0500
Cc: xfs@xxxxxxxxxxx
In-reply-to: <20091009212150.2b54cb77@xxxxxxxxxxxxxx>
References: <20091009170937.3938ff7b@xxxxxxxxxxxxxxxxxxxx> <4ACF8801.7070009@xxxxxxxxxxx> <20091009212150.2b54cb77@xxxxxxxxxxxxxx>
User-agent: Thunderbird 2.0.0.21 (X11/20090320)
Emmanuel Florac wrote:
> Le Fri, 09 Oct 2009 13:59:13 -0500 vous écriviez:
> 
>> try mount -o norecovery (and maybe -o nobarrier)
> 
> Thank you, that worked.
> 
> I can't help but think that when given the "ro" option, XFS shouldn't
> try to write a single bit to the underlying device, or else what's the
> point?

For a dirty log, we do still recover -unless- the underlying device is
RO.  Otherwise you get a corrupt fs mounted ro.... other filesystems do
the same thing, FWIW.

For a clean log I agree; what kernel was this?  I vaguely remember a fix
in this area.

Which option solved it?  (norecovery I'm guessing)

-Eric

<Prev in Thread] Current Thread [Next in Thread>