xfs
[Top] [All Lists]

Re: can't mount XFS from a read-only device

To: Emmanuel Florac <eflorac@xxxxxxxxxxxxxx>
Subject: Re: can't mount XFS from a read-only device
From: Eric Sandeen <sandeen@xxxxxxxxxxx>
Date: Fri, 09 Oct 2009 13:59:13 -0500
Cc: xfs@xxxxxxxxxxx
In-reply-to: <20091009170937.3938ff7b@xxxxxxxxxxxxxxxxxxxx>
References: <20091009170937.3938ff7b@xxxxxxxxxxxxxxxxxxxx>
User-agent: Thunderbird 2.0.0.21 (X11/20090320)
Emmanuel Florac wrote:
> Hello all, 
> 
> I'm using a RAID enclosure that provides read-only snapshots. It works
> perfectly fine using JFS.
> But with XFS, I keep trying and it keeps failing :
> 
> XFS mounting filesystem sdb
> 
> Ending clean XFS mount for filesystem: sdb
> 
> sd 11:0:0:1: [sdc] Result: hostbyte=DID_OK
> driverbyte=DRIVER_SENSE,SUGGEST_OK
> 
> sd 11:0:0:1: [sdc] Sense Key : Data Protect [current] 
> 
> sd 11:0:0:1: [sdc] Add. Sense: Write protected
> end_request: I/O error, dev sdc, sector 0
> Filesystem "sdc": Disabling barriers, trial barrier write failed
> XFS mounting filesystem sdc
> 
> sd 11:0:0:1: [sdc] Result: hostbyte=DID_OK
> driverbyte=DRIVER_SENSE,SUGGEST_OK
> 
> sd 11:0:0:1: [sdc] Sense Key : Data Protect [current] 
> 
> sd 11:0:0:1: [sdc] Add. Sense: Write protected
> end_request: I/O error, dev sdc, sector 1953792056
> xfs_force_shutdown(sdc,0x1) called from line 420 of file
> fs/xfs/xfs_rw.c.  Return address = 0xffffffff80381f89
> 
> Filesystem "sdc": I/O Error Detected.  Shutting down filesystem: sdc
> 
> Please umount the filesystem, and rectify the problem(s)
> 
> I/O error in filesystem ("sdc") meta-data dev sdc block
> 0x74748038       ("xlog_bwrite") error 5 buf count 262144
> 
> XFS: failed to locate log tail
> XFS: log mount/recovery failed: error 5
> XFS: log mount failed
> 
> I don't really grasp what's wrong...
> 

try mount -o norecovery (and maybe -o nobarrier)

-Eric

<Prev in Thread] Current Thread [Next in Thread>