xfs
[Top] [All Lists]

problems with xfs_growfs after lvextend

To: xfs@xxxxxxxxxxx
Subject: problems with xfs_growfs after lvextend
From: Jimmy Dorff <jdorff@xxxxxxxxxxxx>
Date: Wed, 23 Sep 2009 17:04:22 -0400
User-agent: Thunderbird 2.0.0.23 (Macintosh/20090812)
Hello,

I'm having a problem with a corrupt xfs filesystem after attempting to grow the filesystem.

The problem is very similar to this post:
http://www.redhat.com/archives/linux-lvm/2005-November/msg00026.html
Except that xfs_repair never finds a secondary superblock.

Details:
CentOS Linux,
kernel 2.6.18-128.1.16.el5.centos.plus x86_64
lvm2-2.02.40-6.el5
originally: xfsprogs-2.9.4-1.el5.centos.x86_64

This sever has been up and running for a few months w/o problems. Today we added some disks to a 3ware controller. The disks were all tested individually before installation.

Used "tw_cli" to configure a new RAID volume, which appeared in Linux as normal (/dev/sdd).

# pvcreate /dev/sdd
# vgextend array_vg /dev/sdd
# lvextend /dev/array_vg/data --size +12T

This all worked w/o any errors. vgdisplay and lvdisplay all report the correct info and sizes.

The 6TB xfs filesystem on /dev/array_vg/data was mounted as "/srv/data"
# xfs_growfs /srv/data

The size of the filesystem didn't change. I unmounted it and tried again, but no change. However, now I can't mount the filesystem at all.

xfs_check causes xfs_db to use so much memory as to hang up the system.
xfs_repair reports:
Phase 1 - find and verify superblock...
superblock read failed, offset 19791209299968, size 2048, ag 96, rval 0

fatal error -- Invalid argument

Also, I've noticed this in syslog:
kernel: attempt to access beyond end of device
kernel: dm-1: rw=0, want=64424509440, limit=38654705664
kernel: I/O error in filesystem ("dm-1") meta-data dev dm-1 block 0xeffffffff ("xfs_read_buf") error 5 buf count 512
kernel: XFS: size check 2 failed


I've trying using xfs_repair from xfsprogs 3.0.3, but it made no difference.

Any suggestions ? Any help understanding why this didn't work ?


Thanks,
Jimmy Dorff

<Prev in Thread] Current Thread [Next in Thread>