xfs
[Top] [All Lists]

corrupt dinode but xfs_check and xfs_repair are bit detecting any proble

To: xfs@xxxxxxxxxxx
Subject: corrupt dinode but xfs_check and xfs_repair are bit detecting any problem and are fixing nothing.
From: Zoran Cvetkovic <Zoran.Cvetkovic@xxxxxxxxxx>
Date: Fri, 07 Aug 2009 13:39:17 +0200
User-agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; de-AT; rv:1.8.1.19) Gecko/20081204 SeaMonkey/1.1.14
Hi Fellows,

I am running a 2.6.26 kernel on debian lenny having a 6 TB data partition under xfs, 2.6 TB are in use now.
xfs fs is exported via nfs from that box.

after 12 weeks of popper service suddenly nfs performance was a disaster and the box was stuttering, system load was about 10.
There was no indication  for a  hardware problem. HW Raid status was *OK*

/var/log/messages lists several thousand lines like:

Aug 6 21:12:03 nfsserver kernel: [7660448.840139] Filesystem "sdb1": corrupt dinode 4806258, (btree extents). Unmount and run xfs_repair.

(allways the same dinode #)

after stopping nfsd and unmounting the fs

both xfs_check and xfs_repaier did not detect any corruption!

back in service i got the same problem and log lines.

So what is wrong here?

There might be a fs issue and the fs utilitys are not able to detect it ?

I did a metadata dump of that fs and could post it, would this help to determine what is going wrong here?

Regards,
Zoran Cvetkovic

<Prev in Thread] Current Thread [Next in Thread>
  • corrupt dinode but xfs_check and xfs_repair are bit detecting any problem and are fixing nothing., Zoran Cvetkovic <=