xfs
[Top] [All Lists]

Re: How to solve "No space left" problem on my 32bit machine?

To: Eric Sandeen <sandeen@xxxxxxxxxxx>
Subject: Re: How to solve "No space left" problem on my 32bit machine?
From: hank peng <pengxihan@xxxxxxxxx>
Date: Thu, 6 Aug 2009 16:47:34 +0800
Cc: linux-xfs@xxxxxxxxxxx
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:in-reply-to:references :date:message-id:subject:from:to:cc:content-type :content-transfer-encoding; bh=hlQNSCSpkBbqSVLIqZ3Zg+Crc7LYQJl+2QtknXhpmBo=; b=lJmguSkNZkv1wnb/pWGP34EeFV6hpR0+89wdjyJa1rv9vRjAna6ruX5pP9MmTSuV9b Pq6xUTLK1On0MIRAWWWhQxUq/yTeOaW4ahpF90+VDrSJWq2eFjmVWus0WuaKcCovm7LB guj/LFfBzoCr6IWI3X4aitl4azNCNxMR8Rfas=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type:content-transfer-encoding; b=kimGafP54Tf89s5h+8uRGOPdyKuYVF77l5dv9naB0+jQbIofyNJYfw43p7tZFOYVwE +LlkUBvvkdVYaXSqWe7uvbzxLadRoP2Gu0AnSF2un9Z0sflkHT6NTFuRjS+5aLpuyjJI NHZgKAE0Q6yOD1WmglK5gYeAzwnS+CE9FUFOQ=
In-reply-to: <4A7732BF.6020207@xxxxxxxxxxx>
References: <389deec70907252030s3524b2ecj9b35da9ea376020f@xxxxxxxxxxxxxx> <4A6D075B.9060601@xxxxxxxxxxx> <389deec70907262347g1ca3637fn469596ec1e05148@xxxxxxxxxxxxxx> <4A6DAE5D.6060704@xxxxxxxxxxx> <389deec70908030732n29d35220mc9acdb912ab10899@xxxxxxxxxxxxxx> <4A7732BF.6020207@xxxxxxxxxxx>
2009/8/4 Eric Sandeen <sandeen@xxxxxxxxxxx>:
> hank peng wrote:
>> 2009/7/27 Eric Sandeen <sandeen@xxxxxxxxxxx>:
>>> hank peng wrote:
>>>> 2009/7/27 Eric Sandeen <sandeen@xxxxxxxxxxx>:
>>>>> hank peng wrote:
>>>>>> Hi, folks:
>>>>>> I have a 2.5T file system formatted with XFS, df tells me it still
>>>>>> have about 10G space available, but I can't create new files or
>>>>>> directory any more. Return message is "No space left on this device".
>>>>>> I searched solution for this problem through google, and found this:
>>>>>> http://oss.sgi.com/archives/xfs/2005-06/msg00347.html. I think it is a
>>>>>> known "No space left" problem. I wonder whether it can only
>>>>>> be solved on 64-bit machine? If on my 32-bit machine, what should I do?
>>>>> On very recent kernels you can use 64-bit inodes on 32-bit machines; you
>>>>> can try mounting with -o inode64 t allow this.
>>>>>
>>>> I tried -o inode64 option, but kernel gives me error message:
>>>> XFS: inode64 option not allowed on this system
>>>> I doubt this option can't be used on 32-bit machine.
>>> That's why I said you need a very recent kernel, it was added relatively
>>> recently:
>>>
>>> commit 6c31b93a14a453c8756ffd228e24910ffdf30c5d
>>> Author: Christoph Hellwig <hch@xxxxxxxxxxxxx>
>>> Date:   Fri Nov 28 14:23:32 2008 +1100
>>>
>>>    [XFS] allow inode64 mount option on 32 bit systems
>>>
>>> I believe this went into 2.6.29.
>>>
>> I tried 2.6.30 and test it
>> 1. create an exact 2T LVM
>> 2. create XFS on it
>> 3. mont it with inode64 option
>> 4. write files on it to full extent
>> 5. use xfs_grow to expand it to 2.5T
>> 6. touch a file and no error message returned
>> 7. 'ls -l' can not show the file I created above.
>>
>> So I think I should do something on userspace tools, but how?
>
> Doesn't sound like a userspace problem.  So touch succeeds (maybe echo
> $? after to be sure) but ls shows no file?  Anything in dmesg after that?
>
> I'd have to find a 32-bit box w/ > 2T to test this I guess.  :)
>
It is because I use "ls" command in old version of busybox, after I
update busybox to the latest, it is OK now.

I don't check the source code of old version, but i am sure it is the reason.



> -Eric
>



-- 
The simplest is not all best but the best is surely the simplest!

<Prev in Thread] Current Thread [Next in Thread>