[Top] [All Lists]

Re: How to solve "No space left" problem on my 32bit machine?

To: Eric Sandeen <sandeen@xxxxxxxxxxx>
Subject: Re: How to solve "No space left" problem on my 32bit machine?
From: hank peng <pengxihan@xxxxxxxxx>
Date: Mon, 3 Aug 2009 22:32:47 +0800
Cc: linux-xfs@xxxxxxxxxxx
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:in-reply-to:references :date:message-id:subject:from:to:cc:content-type :content-transfer-encoding; bh=CR4SNCxoe9sPfyR0y90OrPINBqROJqk/jkRmSu+u3wo=; b=k1lnm3rCz4WxupYg4o3hg9H3hx7eizuQ+cbvNfGluLr2nb+kU5vsDyXe3ySMzp+OY6 ma6IfVTd1wvKiULK97Qsd51yNVr0LDZ05j5zCckoA5Nxz6Hnu2JTuEW9tu1zHbuC6aN2 SfwcjlOiI2bfdUQOmCT5cCo1i8XCjwzKHG8Sg=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type:content-transfer-encoding; b=MNDUzIERzP54SNh+EOfDqk3ano9jv0Zq+6u9Z3fHAAZ5AQ8Xy4ZMu26xXsTFZho9jo Xc8/B57U+slfuMrP9aZq94/qIbOe3TIyE7OcXIQQb3JSuQo5swj9EA7ZOB8A/HoVxEsW 5eUxc6dOkfJ6cBRo0Hs8gFsIrY5XZtEgJKDeM=
In-reply-to: <4A6DAE5D.6060704@xxxxxxxxxxx>
References: <389deec70907252030s3524b2ecj9b35da9ea376020f@xxxxxxxxxxxxxx> <4A6D075B.9060601@xxxxxxxxxxx> <389deec70907262347g1ca3637fn469596ec1e05148@xxxxxxxxxxxxxx> <4A6DAE5D.6060704@xxxxxxxxxxx>
2009/7/27 Eric Sandeen <sandeen@xxxxxxxxxxx>:
> hank peng wrote:
>> 2009/7/27 Eric Sandeen <sandeen@xxxxxxxxxxx>:
>>> hank peng wrote:
>>>> Hi, folks:
>>>> I have a 2.5T file system formatted with XFS, df tells me it still
>>>> have about 10G space available, but I can't create new files or
>>>> directory any more. Return message is "No space left on this device".
>>>> I searched solution for this problem through google, and found this:
>>>> http://oss.sgi.com/archives/xfs/2005-06/msg00347.html. I think it is a
>>>> known "No space left" problem. I wonder whether it can only
>>>> be solved on 64-bit machine? If on my 32-bit machine, what should I do?
>>> On very recent kernels you can use 64-bit inodes on 32-bit machines; you
>>> can try mounting with -o inode64 t allow this.
>> I tried -o inode64 option, but kernel gives me error message:
>> XFS: inode64 option not allowed on this system
>> I doubt this option can't be used on 32-bit machine.
> That's why I said you need a very recent kernel, it was added relatively
> recently:
> commit 6c31b93a14a453c8756ffd228e24910ffdf30c5d
> Author: Christoph Hellwig <hch@xxxxxxxxxxxxx>
> Date:   Fri Nov 28 14:23:32 2008 +1100
>    [XFS] allow inode64 mount option on 32 bit systems
> I believe this went into 2.6.29.
I tried 2.6.30 and test it
1. create an exact 2T LVM
2. create XFS on it
3. mont it with inode64 option
4. write files on it to full extent
5. use xfs_grow to expand it to 2.5T
6. touch a file and no error message returned
7. 'ls -l' can not show the file I created above.

So I think I should do something on userspace tools, but how?
> -Eric

The simplest is not all best but the best is surely the simplest!

<Prev in Thread] Current Thread [Next in Thread>