xfs
[Top] [All Lists]

Re: How to solve "No space left" problem on my 32bit machine?

To: Eric Sandeen <sandeen@xxxxxxxxxxx>
Subject: Re: How to solve "No space left" problem on my 32bit machine?
From: hank peng <pengxihan@xxxxxxxxx>
Date: Mon, 27 Jul 2009 23:48:51 +0800
Cc: linux-xfs@xxxxxxxxxxx
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:in-reply-to:references :date:message-id:subject:from:to:cc:content-type :content-transfer-encoding; bh=hwrhScluzvJT+255bMQvCVLojQ8o7IMv1v2Dyb/vqeE=; b=nhYlZ5LEp6nV1xkx63f67BRpgZVkg0RAY7muPTYrj77tk59FJdSImdNm9d7Ol3PWED goOIy6nbtchiIxvFZaahCox588v89ad5NgiEwlSG5XBpnbXlyW9KKVHtc9qABh+swYsu ypHluzQNIsFbfS9NMDSRwv0NCNP0+HYuOIxd0=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type:content-transfer-encoding; b=KoJb8r9IsqS8BBSg62RNCpVtw9e+vOGSr5m1aaGIhOz9zKRwVS76/59ItQPBhQBZ66 x5+J7LZBoZpyoc46/FK7gFbUybR08wquLU7RSTWNtWpDel4u3YAzwIM2GqpeW/ysXqFr BlM7rR7rtIWU163rtlFecj71Xtrh5uSHLIvrk=
In-reply-to: <4A6DAE5D.6060704@xxxxxxxxxxx>
References: <389deec70907252030s3524b2ecj9b35da9ea376020f@xxxxxxxxxxxxxx> <4A6D075B.9060601@xxxxxxxxxxx> <389deec70907262347g1ca3637fn469596ec1e05148@xxxxxxxxxxxxxx> <4A6DAE5D.6060704@xxxxxxxxxxx>
2009/7/27 Eric Sandeen <sandeen@xxxxxxxxxxx>:
> hank peng wrote:
>> 2009/7/27 Eric Sandeen <sandeen@xxxxxxxxxxx>:
>>> hank peng wrote:
>>>> Hi, folks:
>>>> I have a 2.5T file system formatted with XFS, df tells me it still
>>>> have about 10G space available, but I can't create new files or
>>>> directory any more. Return message is "No space left on this device".
>>>> I searched solution for this problem through google, and found this:
>>>> http://oss.sgi.com/archives/xfs/2005-06/msg00347.html. I think it is a
>>>> known "No space left" problem. I wonder whether it can only
>>>> be solved on 64-bit machine? If on my 32-bit machine, what should I do?
>>> On very recent kernels you can use 64-bit inodes on 32-bit machines; you
>>> can try mounting with -o inode64 t allow this.
>>>
>> I tried -o inode64 option, but kernel gives me error message:
>> XFS: inode64 option not allowed on this system
>> I doubt this option can't be used on 32-bit machine.
>
> That's why I said you need a very recent kernel, it was added relatively
> recently:
>
> commit 6c31b93a14a453c8756ffd228e24910ffdf30c5d
> Author: Christoph Hellwig <hch@xxxxxxxxxxxxx>
> Date:   Fri Nov 28 14:23:32 2008 +1100
>
>    [XFS] allow inode64 mount option on 32 bit systems
>
> I believe this went into 2.6.29.
>
thx, i will try ASAP
> -Eric
>
>



-- 
The simplest is not all best but the best is surely the simplest!

<Prev in Thread] Current Thread [Next in Thread>