xfs
[Top] [All Lists]

Re: How to solve "No space left" problem on my 32bit machine?

To: hank peng <pengxihan@xxxxxxxxx>
Subject: Re: How to solve "No space left" problem on my 32bit machine?
From: Eric Sandeen <sandeen@xxxxxxxxxxx>
Date: Mon, 27 Jul 2009 08:40:45 -0500
Cc: linux-xfs@xxxxxxxxxxx
In-reply-to: <389deec70907262347g1ca3637fn469596ec1e05148@xxxxxxxxxxxxxx>
References: <389deec70907252030s3524b2ecj9b35da9ea376020f@xxxxxxxxxxxxxx> <4A6D075B.9060601@xxxxxxxxxxx> <389deec70907262347g1ca3637fn469596ec1e05148@xxxxxxxxxxxxxx>
User-agent: Thunderbird 2.0.0.22 (Macintosh/20090605)
hank peng wrote:
> 2009/7/27 Eric Sandeen <sandeen@xxxxxxxxxxx>:
>> hank peng wrote:
>>> Hi, folks:
>>> I have a 2.5T file system formatted with XFS, df tells me it still
>>> have about 10G space available, but I can't create new files or
>>> directory any more. Return message is "No space left on this device".
>>> I searched solution for this problem through google, and found this:
>>> http://oss.sgi.com/archives/xfs/2005-06/msg00347.html. I think it is a
>>> known "No space left" problem. I wonder whether it can only
>>> be solved on 64-bit machine? If on my 32-bit machine, what should I do?
>> On very recent kernels you can use 64-bit inodes on 32-bit machines; you
>> can try mounting with -o inode64 t allow this.
>>
> I tried -o inode64 option, but kernel gives me error message:
> XFS: inode64 option not allowed on this system
> I doubt this option can't be used on 32-bit machine.

That's why I said you need a very recent kernel, it was added relatively
recently:

commit 6c31b93a14a453c8756ffd228e24910ffdf30c5d
Author: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date:   Fri Nov 28 14:23:32 2008 +1100

    [XFS] allow inode64 mount option on 32 bit systems

I believe this went into 2.6.29.

-Eric

<Prev in Thread] Current Thread [Next in Thread>