xfs
[Top] [All Lists]

Re: Using xfsdump On Linux With IRIX Version 1 FS?

To: Eric Sandeen <sandeen@xxxxxxxxxxx>
Subject: Re: Using xfsdump On Linux With IRIX Version 1 FS?
From: Sean Elble <elbles@xxxxxxxxxx>
Date: Thu, 23 Jul 2009 23:32:21 -0400
Cc: <xfs@xxxxxxxxxxx>
In-reply-to: <4A691B2D.1090600@xxxxxxxxxxx>
Thread-index: AcoMD1omsd4KSHDKKEyPjVu66qkNxg==
Thread-topic: Using xfsdump On Linux With IRIX Version 1 FS?
User-agent: Microsoft-Entourage/12.20.0.090605
On 7/23/09 10:23 PM, "Eric Sandeen" <sandeen@xxxxxxxxxxx> wrote:

> Sean Elble wrote:
>> Hi all,
>> 
>> While I am aware that the current kernel implementation of XFS doesn't
>> support mounting an IRIX filesystem with version 1 directories, I'm not so
>> sure whether xfsdump/xfsrestore will support the dumping of an IRIX
>> filesystem with version 1 directories.  To be more specific, I am dealing
>> with an old disk from an Indigo2, running IRIX 6.5.6m with version 1
>> (0x1094) directories.  I was hoping it had version 2 directories, but after
>> finding an old SCSI card I could put in a Linux box with XFS support, I
>> found just the opposite, obviously.  I had the old SCSI card back in its
>> donor system (which was up-and-running) when it occurred to me that
>> xfsdump/xfsrestore *might* be a possibility, and I can't take it (the donor
>> system) down again unless I know I can make this work.
>> 
>> If anyone can give me an answer to this question, I would certainly
>> appreciate it.  I didn't see anything in the man pages, and my Google
>> searches have proven fruitless thus far, but I've been known to be blind on
>> occasion.  :-)  Thanks, in advance.
>> 
> 
> linux used to work with v1 dirs, though there were some problems.  It
> never got fixed, was not critical for 99.9% of users, and got taken out.
>  But it might work well enough to do what you need.  Go through the
> changelogs or google, and try an older Linux kernel, perhaps ....
> 
> -Eric
> 

Looks like the version 1 directory code was removed as of June 15th, 2006,
per this:

http://oss.sgi.com/archives/xfs/2006-06/msg00067.html

But another post <http://oss.sgi.com/archives/xfs/2003-07/msg00495.html> has
a 2.4.21 kernel being used with a patch, so I'm not sure if I want to try a
2.6 kernel, or see if I can patch together a 2.4.x kernel on an old FC4 box
I have laying around.  Truth be told, it's a lot of work just to blank the
entries in /etc/shadow so I can login to a 150 MHz box again, so who knows
if I'll even try at this point, hah.

In any event, thanks a lot for the pointers in the right direction.

-Sean

Attachment: smime.p7s
Description: S/MIME cryptographic signature

<Prev in Thread] Current Thread [Next in Thread>