xfs
[Top] [All Lists]

Re: 2.6.30-rc6: BUG at fs/xfs/support/debug.c:109!

To: Dave Chinner <david@xxxxxxxxxxxxx>
Subject: Re: 2.6.30-rc6: BUG at fs/xfs/support/debug.c:109!
From: Alexander Beregalov <a.beregalov@xxxxxxxxx>
Date: Wed, 1 Jul 2009 20:21:20 +0400
Cc: Kernel Testers List <kernel-testers@xxxxxxxxxxxxxxx>, xfs@xxxxxxxxxxx
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:in-reply-to:references :date:message-id:subject:from:to:cc:content-type :content-transfer-encoding; bh=38TWLhQghkcnwHj4DIpwACcmzjEtABa/+BRxdJLRDFY=; b=a+loPMJqpoqIHeE3s1CS+6DPGSiHhOqfXfVIbGYimWKL3GUnjjJMXRmuDhFdfmsRFs 53DzZYn/tmAUpS4K0opjL8oyrB0SR6eVO7nQQx9IHA3S7J9iPJt2iQuXjHRc/NuTs8cw L+bYVVDK0dDZI41KU00ixvkYbOpyr8klHIO+Y=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type:content-transfer-encoding; b=tpA5JgY1S/Ofxft9QWid5YX8sO0jZqsopjjnKxwRjOEVREJFbIb5THYEMz6myqfXUO AgR57PknffM6CDanjufA1KpzHnhW9RloSWSaWaCrL0mzxek2EqfkeXVt6reKkoL/kuNf 71V1W34Xun3Mn8TzU65DDtiMtdKjPI5RdBcjg=
In-reply-to: <a4423d670906050223p4e72ceaaqa1dd942a2e52d1a3@xxxxxxxxxxxxxx>
References: <a4423d670906010822l6e8e112dl3d6f7de9e2179850@xxxxxxxxxxxxxx> <20090604092330.GT16929@xxxxxxxxxxxxxxxx> <a4423d670906050223p4e72ceaaqa1dd942a2e52d1a3@xxxxxxxxxxxxxx>
2009/6/5 Alexander Beregalov <a.beregalov@xxxxxxxxx>:
> 2009/6/4 Dave Chinner <david@xxxxxxxxxxxxx>:
>> On Mon, Jun 01, 2009 at 07:22:56PM +0400, Alexander Beregalov wrote:
>>> Hi
>>>
>>> Assertion failed: *nmap >= 1, file: fs/xfs/xfs_bmap.c, line: 4846
>> .....
>>> Call Trace:
>>>  [<ffffffff803d6bad>] xfs_bmapi+0xad/0x1ad0
>>>  [<ffffffff803ee5c0>] xfs_dir2_leaf_getdents+0x640/0x7b0
>>>  [<ffffffff803e975c>] xfs_readdir+0x12c/0x140
>>>  [<ffffffff80430b57>] xfs_file_readdir+0x47/0x70
>>>  [<ffffffff802ec500>] vfs_readdir+0xd0/0xf0
>>>  [<ffffffff802ec6b6>] sys_getdents+0x96/0x110
>>>  [<ffffffff8020ba6b>] system_call_fastpath+0x16/0x1b
>>
>> I'd say this indicates a corrupted directory.  Can you run
>> 'xfs_repair -n' over the filesystem and see if it finds a bad
>> directory?

Still cannot fix the filesystem. After repairing all corruptions from
LiveCD it still fails on the same workload.

Do you need metadump or anything else?

<Prev in Thread] Current Thread [Next in Thread>