xfs
[Top] [All Lists]

RE: xfs_growfs doesn't grow on 2TB raid

To: <mw@xxxxxxxxxxxx>
Subject: RE: xfs_growfs doesn't grow on 2TB raid
From: jack the ripper <evil_metalpeet@xxxxxxxxxxx>
Date: Wed, 10 Jun 2009 17:54:20 +0200
Cc: <xfs@xxxxxxxxxxx>
Importance: Normal
In-reply-to: <4A2FAFA0.9020408@xxxxxxxxxxxx>
References: <BAY108-W1262BA63B7F70EB6364C9AF3450@xxxxxxx> <00ee01c9e9c5$4cf36b20$e6da4160$@monnerie@is.it-management.at> <BAY108-W43AAADA49E758366E8F23AF3450@xxxxxxx> <4A2FAFA0.9020408@xxxxxxxxxxxx>
I had not done the reboot (I'm not used to that anymore with linux). I did now though and everything is solved:

RoSe v1per # /root/mount.data1
mdadm: /dev/mddata1 has been started with 6 drives.
Enter LUKS passphrase:
key slot 0 unlocked.
Command successful.

RoSe v1per # xfs_growfs /mnt/data1/
meta-data="" isize=256    agcount=9, agsize=61047928 blks
         =                       sectsz=512   attr=2
data     =                       bsize=4096   blocks=488383679, imaxpct=25
         =                       sunit=0      swidth=0 blks
naming   =version 2              bsize=4096   ascii-ci=0
log      =internal               bsize=4096   blocks=32768, version=2
         =                       sectsz=512   sunit=0 blks, lazy-count=0
realtime =none                   extsz=4096   blocks=0, rtextents=0
data blocks changed from 488383679 to 610479663

RoSe v1per # df --si
Filesystem             Size   Used  Avail Use% Mounted on
udev                    11M   349k    11M   4% /dev
shm                    1.1G      0   1.1G   0% /dev/shm
/dev/mapper/data1      2.6T   1.9T   655G  74% /mnt/data1

Thank you all for helping me so quickly and sorry for bothering all of you with the solution being so simple!

> Date: Wed, 10 Jun 2009 15:05:36 +0200
> From: mw@xxxxxxxxxxxx
> To: evil_metalpeet@xxxxxxxxxxx
> CC: xfs@xxxxxxxxxxx
> Subject: Re: xfs_growfs doesn't grow on 2TB raid
>
> > Can you confirm that I need GPT for my software raid?
> You don't need GPT for software RAID unless one of your disks is >2TB. For example I am running a 3TB XFS file system directly on /dev/md0. Have you done a reboot, maybe the new size has not really been applied? Never tried it with LUKS/cryptsetup though, maybe it won't to above 2GB.
>
> # df -h /dev/md0
> Filesystem Size Used Avail Use% Mounted on
> /dev/md0 2.8T 1.5T 1.4T 53% /san1
>
> hth Michael


Je hele online leven op één stek? Ontdek Windows Live!
<Prev in Thread] Current Thread [Next in Thread>