[Top] [All Lists]

Re: Segmentation fault during xfs_repair

To: Richard Kolkovich <richard@xxxxxxxxxxxxx>
Subject: Re: Segmentation fault during xfs_repair
From: Eric Sandeen <sandeen@xxxxxxxxxxx>
Date: Fri, 05 Jun 2009 22:25:21 -0500
Cc: "xfs@xxxxxxxxxxx" <xfs@xxxxxxxxxxx>
In-reply-to: <20090606031445.GB39825@xxxxxxxxxxxxxxxxxxxxxx>
References: <20090605222236.GA39825@xxxxxxxxxxxxxxxxxxxxxx> <4A29D851.9000700@xxxxxxxxxxx> <20090606031445.GB39825@xxxxxxxxxxxxxxxxxxxxxx>
User-agent: Thunderbird (Macintosh/20090302)
Richard Kolkovich wrote:
> On Fri, Jun 05, 2009 at 10:45:37PM -0400, Eric Sandeen wrote:
>> Richard Kolkovich wrote:
>>> We have a corrupted XFS partition on a storage server.
>>> Attempting to run xfs_repair the first time yielded the message
>>> about a corrupt log file, so I have run xfs_repair with -L to
>>> clear that.  Now, xfs_repair segfaults in Phase 3.  I have tried
>>> -P and a huge -m to no avail.  It always seems to segfault at the
>>> same point:
>>> bad directory block magic # 0 in block 11 for directory inode
>>> 341521797 corrupt block 11 in directory inode 341521797 will junk
>>> block Segmentation fault (core dumped)
>> For starters, which xfsprogs version.... if not latest, try
>> latest... if latest, I'll grab that metadump image and see if I can
>> reproduce it.
>> -Eric
> Sorry - forgot to mention that.
> Running on Fedora 11 (64bit).  Tried using 2.10.2 (from yum) and
> building from latest stable source (3.0.1).  Let me know if I should
> try a dev build.

(Hm, did I really leave F11 at 2.10.2?  I thought it was newer, but anyway)

No, I doubt anything else has fixed this since 3.0.1

I'll try pulling down that metadump image & see what I can see.

Feel free to file an xfsprogs bug with fedora, too, so the issue doesn't
get lost...


> Thanks,

<Prev in Thread] Current Thread [Next in Thread>