xfs
[Top] [All Lists]

Re: Segmentation fault during xfs_repair

To: Eric Sandeen <sandeen@xxxxxxxxxxx>
Subject: Re: Segmentation fault during xfs_repair
From: Richard Kolkovich <richard@xxxxxxxxxxxxx>
Date: Fri, 5 Jun 2009 22:14:46 -0500
Cc: "xfs@xxxxxxxxxxx" <xfs@xxxxxxxxxxx>
In-reply-to: <4A29D851.9000700@xxxxxxxxxxx>
References: <20090605222236.GA39825@xxxxxxxxxxxxxxxxxxxxxx> <4A29D851.9000700@xxxxxxxxxxx>
User-agent: Mutt/1.5.19 (2009-01-05)
On Fri, Jun 05, 2009 at 10:45:37PM -0400, Eric Sandeen wrote:
> Richard Kolkovich wrote:
> > We have a corrupted XFS partition on a storage server.  Attempting to run 
> > xfs_repair the first time yielded the message about a corrupt log file, so 
> > I have run xfs_repair with -L to clear that.  Now, xfs_repair segfaults in 
> > Phase 3.  I have tried -P and a huge -m to no avail.  It always seems to 
> > segfault at the same point:
> > 
> > bad directory block magic # 0 in block 11 for directory inode 341521797
> > corrupt block 11 in directory inode 341521797
> >         will junk block
> > Segmentation fault (core dumped)
> 
> For starters, which xfsprogs version.... if not latest, try latest... if
> latest, I'll grab that metadump image and see if I can reproduce it.
> 
> -Eric

Sorry - forgot to mention that.

Running on Fedora 11 (64bit).  Tried using 2.10.2 (from yum) and building from 
latest stable source (3.0.1).  Let me know if I should try a dev build.

Thanks,

-- 

Richard Kolkovich
IntraMeta Corporation
richard@xxxxxxxxxxxxx

<Prev in Thread] Current Thread [Next in Thread>