xfs
[Top] [All Lists]

Re: xfs_growfs: XFS_IOC_FSGROWFSDATA xfsctl failed: Invalid argument

To: richard.ems@xxxxxxxxxxxxxxxxx
Subject: Re: xfs_growfs: XFS_IOC_FSGROWFSDATA xfsctl failed: Invalid argument
From: Eric Sandeen <sandeen@xxxxxxxxxxx>
Date: Sat, 23 May 2009 12:35:19 -0500
Cc: xfs@xxxxxxxxxxx
In-reply-to: <20090523180721.94212hyfjppuupmo@xxxxxxxxxxxxx>
References: <4A180FCD.9080905@xxxxxxxxxxxxxxxxx> <4A181B40.9080608@xxxxxxxxxxx> <20090523180721.94212hyfjppuupmo@xxxxxxxxxxxxx>
User-agent: Thunderbird 2.0.0.21 (Macintosh/20090302)
richard.ems@xxxxxxxxxxxxxxxxx wrote:
> Quoting Eric Sandeen <sandeen@xxxxxxxxxxx>:
> 
>> Richard Ems wrote:

...

>>> I tried different 2.6.27 versions, one 2.6.29 and one 2.6.30-rc6
>>> version, all gave the same error, check
>>> https://bugzilla.novell.com/show_bug.cgi?id=506361 for the different
>>> kernel versions and errors.
>> I don't see in that bug where you tested .29 or .30, or what the results
>> were...
> 
> Sorry, I wrote a 2nd comment into bugzilla but forgot to submit it 8( .
> Now it's there, please check again (  
> https://bugzilla.novell.com/show_bug.cgi?id=506361#c1 ) .
> 
>>
>>> Is this fix still not included in Linus / openSUSE trees?
>> As for Linus' tree, AFAIK everything works; I can't speak to what SuSE has.
> 
> So the Vanilla kernel I tried should have this fix included, is it  
> then a new bug?

Not sure ... how big is the current fs and how big is the device?  Can
you provide:

# xfs_info /mnt
# grep sda1 /proc/partitions

-Eric

<Prev in Thread] Current Thread [Next in Thread>