xfs
[Top] [All Lists]

Fwd: xfs - fixing wrong xfs size

To: xfs@xxxxxxxxxxx
Subject: Fwd: xfs - fixing wrong xfs size
From: Nebojsa Trpkovic <trx.lists@xxxxxxxxx>
Date: Mon, 13 Apr 2009 18:33:55 +0200
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:in-reply-to:references :date:message-id:subject:from:to:content-type; bh=uNgMi+AP9UJRdedBDeXjixSgWm+11xkBsx62Oidh1uA=; b=cChAqHwdt52t4iej6XNJz1A+VN5jsCvfYMoIWxGMROc6tf1ONfJYYxhiDYYO9KfyBY 6QZnWSs+SmT+MFNsu0BVzpfFhI0xTBqGALzWUkXV0HGCkppq4bbEYyfbrvoKJtAZPdxo uQPFKp9iyB70it5/ZFYN0FRSkCyCrWojRWVqY=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :content-type; b=QFXx4WCj3dHHtP/+UjgThd+dlVwkwi+HgoQSLtpLTm3OkMUd/BnImsFYb4sP1T799r sQ+oemJFJBxzf9HkrL6BkDp95plYgwOCgMrgt4Pn3+jMcs8CdhcOi4rqVgo0dKEh8VfO uihgXk7Tf+Y9LcsTr158d6hXnnkdndXRxY6bM=
In-reply-to: <dbd747120904130913p45c2979eu5afd15f5a6ca7b7f@xxxxxxxxxxxxxx>
References: <dbd747120904130713t7388971axf75ee779b5b1e1f2@xxxxxxxxxxxxxx> <49E353FD.5060207@xxxxxxxxxxx> <dbd747120904130913p45c2979eu5afd15f5a6ca7b7f@xxxxxxxxxxxxxx>
On Mon, Apr 13, 2009 at 5:02 PM, Eric Sandeen <sandeen@xxxxxxxxxxx> wrote:
Nebojsa Trpkovic wrote:
> hello.
>
> I had problem with raid5 on my system.
> after recovering of the array, I can not mount XFS that resides on it.
> I've run xfs_check and xfs_repair (which fixed some errors) and now I
> can run them all day long without any errors.
>
> but, when I try to mount that partition, I get:
>
> mount: /dev/md0: can't read superblock
>
>
> and there's
>
> Filesystem "md0": Disabling barriers, not supported by the underlying device
>
> attempt to access beyond end of device
> md0: rw=0, want=123024384, limit=123023488
> I/O error in filesystem ("md0") meta-data dev md0 block 0x75533f8

      ("xfs_read_buf") error 5 buf count 4096
>
> XFS: size check 2 failed

So, the superblock says that the fs is 896 1k-blocks longer than the
device actually is.

> in the dmesg.
>
>
> is there any way to "fix" this wrong size of XFS ?

hard to say, almost certainly sounds like an md problem; is there a
chance that your raid recovery led to a device which is somehow smaller
than it started?  You could change the superblock block-count value, but
I'm guessing that something else has gone wrong.

It might be useful to know what errors xfs_repair found.

-Eric


thx for quick reply.

yes, I definitely had md problem - my raid5 made of 6 drives connected to ICH9R and 2 drives connected to the masterpeace of hardware called JMicron fell apart when later one just stopped working out of nowhere. after reboot, JMicron worked well, but raid was out of sync with 2 members failed. I've zeroed superblocks of raid partitions and created new one with "assume-clear". partition tables stayed intact - I had no need to change anything in them. that worked fine with /dev/md1 wich had reiserfs: after long and slow reiserfs --rebuild-tree I'm able to access all files on that partition. unforutuately, I have no way to mount xfs partition although xfs_check and xfs_repair give no errors (I had to run xfs_repair -L /dev/md0 to get in this error-free situation).

how can I set superblock block-count value (now I have realy nothing to loose - the only other option is to give up of that data) ?



<Prev in Thread] Current Thread [Next in Thread>