xfs
[Top] [All Lists]

[PATCH] xfsprogs spec file update

To: xfs@xxxxxxxxxxx
Subject: [PATCH] xfsprogs spec file update
From: Nathan Scott <nscott@xxxxxxxxxx>
Date: Sat, 24 Jan 2009 17:14:27 +1100
Since binaries have moved between xfsprogs and xfsdump packages
in version 3.0.0, we need to fix the dependencies in the rpm
specfiles, else rpm will complain.

While in there, remove xfs-cmds Provides/Obsoletes lines, there
is no way anyone is ever going to be requiring those anymore (no
real-world upgrade path having such old skool SGI-released rpms).

diff --git a/build/rpm/xfsprogs.spec.in b/build/rpm/xfsprogs.spec.in
index 2826a37..cf61225 100644
--- a/build/rpm/xfsprogs.spec.in
+++ b/build/rpm/xfsprogs.spec.in
@@ -5,10 +5,8 @@ Release: @pkg_release@
 Distribution: @pkg_distribution@
 Packager: Silicon Graphics, Inc. <http://www.sgi.com/>
 BuildRoot: @build_root@ 
-Provides: xfs-cmds
-Obsoletes: xfs-cmds
 Prereq: /sbin/ldconfig
-Conflicts: xfsdump < 2.0.0
+Conflicts: xfsdump < 3.0.0
 Source: @pkg_name@-@pkg_version@.src.tar.gz
 License: GPL
 Vendor: Silicon Graphics, Inc.
@@ -32,8 +30,8 @@ with the IRIX version of XFS.
 %package devel
 Summary: XFS filesystem-specific static libraries and headers.
 Group: Development/Libraries
-Requires: @pkg_name@ >= 2.0.0
-Conflicts: @pkg_name@ < 2.0.0
+Requires: @pkg_name@ >= 3.0.0
+Conflicts: @pkg_name@ < 3.0.0
 
 %description devel
 xfsprogs-devel contains the libraries and header files needed to


<Prev in Thread] Current Thread [Next in Thread>