xfs
[Top] [All Lists]

Re: problems showing up as XFS problems on kernels after 2.6.28-git2

To: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Subject: Re: problems showing up as XFS problems on kernels after 2.6.28-git2
From: Danny ter Haar <dth@xxxxxxx>
Date: Wed, 7 Jan 2009 19:44:20 +0100
Cc: xfs@xxxxxxxxxxx
In-reply-to: <20090107183115.GA6261@xxxxxxxxxxxxx>
References: <20090107165218.GA11132@xxxxxxx> <20090107180246.GA15218@xxxxxxxxxxxxx> <20090107182415.GA12039@xxxxxxx> <20090107183115.GA6261@xxxxxxxxxxxxx>
User-agent: Mutt/1.5.18 (2008-05-17)
Quoting Christoph Hellwig (hch@xxxxxxxxxxxxx):
> And error when compiling the kernel or you got the same error again?

same error while trying to boot (this time on sda (pata with libata))
root filesystem of the OS partition.

> In case you can actually reproduce this error, I would be very
> interested in a metadump of the filesystem that causes this error.

See the errorlog on: 
http://www.dth.net/kernel/c3/netconsole_2.6.28-git9-error.txt

> The dbuegging should be really easy as long you actually have a tree /
> config 

kernel tree is still on my laptop available.

> with which the oops happened so that the oops has the same
> addresses.
> Compared to your config we would need CONFIG_DEBUG_INFO,
> but that's something we could turn on after the fact as it shouldn't
> change the reported address.  After that we can just do a trivial
> command in gdb to find the source lines for the addresses reported
> (this can easily be done on the system where you compile the kernel,
> doesn't have to be on the NAS box).

ok, pointer to a howto by anychange ?
still looking/googling. [think i found something]

> Btw, turning on CONFIG_XFS_DEBUG would be useful to see more output
> in case you can reproduce this issue.  Just make sure to turn it
> off again when you want to use the box for a real workload..

Will compile a new kernel in the mean time with those 2 options:
CONFIG_XFS_DEBUG & CONFIG_DEBUG_INFO


-- 

<Prev in Thread] Current Thread [Next in Thread>