[Top] [All Lists]

Re: XFS ignores all atime related mount options, noatime is always in ef

To: Roland Eggner <edvx1@xxxxxxxxxxxxxxxxxx>
Subject: Re: XFS ignores all atime related mount options, noatime is always in effect, documentation misses this information
From: Martin Steigerwald <Martin@xxxxxxxxxxxx>
Date: Fri, 19 Dec 2008 14:01:38 +0100
Cc: SGI Project XFS mailing list <xfs@xxxxxxxxxxx>
In-reply-to: <200812181915.13962.edvx1@xxxxxxxxxxxxxxxxxx>
References: <200812181915.13962.edvx1@xxxxxxxxxxxxxxxxxx> (sfid-20081218_195913_535609_9F401C50)
User-agent: KMail/1.9.9
Am Donnerstag 18 Dezember 2008 schrieb Roland Eggner:
> On my linux box I tried to achieve regular atime behaviour, tried mount
> with no atime related option at all, tried mount options atime, sync,
> osyncisosync, .. XFS on plain partitions, on loop devices .. I tried
> another kernel (sidux image with kernel 2.6.25-9) ..
> My result:
> It seems impossible to switch off "noatime" mount option.
> atime updates happen only in core, never on disk unless coinciding with
> other inode modifications, regardless of specified mount options.
> $  uname -a
> Linux roland #2 Tue Apr 15 17:10:52 CEST 2008 i686
> GNU/Linux

I can't reproduce this on

martin@shambhala:~/Zeit> grep /home /proc/mounts
/dev/sda5 /home xfs 
rw,relatime,attr2,nobarrier,logbufs=8,logbsize=256k,noquota 0 0
martin@shambhala:~/Zeit> echo "hallo" >hallo.txt
martin@shambhala:~/Zeit> ls -l --time=atime hallo.txt
-rw-r--r-- 1 martin martin 6 19. Dez 13:56 hallo.txt
martin@shambhala:~/Zeit> cat hallo.txt ; ls -l --time=atime hallo.txt
-rw-r--r-- 1 martin martin 6 19. Dez 13:57 hallo.txt

How did you test it? A reproducable test case would be fine.

> $  zgrep XFS /proc/config.gz
> # CONFIG_XFS_QUOTA is not set
> # CONFIG_VXFS_FS is not set

martin@shambhala:~> zgrep XFS /proc/config.gz
# CONFIG_XFS_DEBUG is not set
# CONFIG_VXFS_FS is not set

> In mailing list archive I found
> http://oss.sgi.com/archives/xfs/2007-10/msg00168.html
> It seems, that 3 years ago an unconditional noatime enforcement has
> been introduced.

Did you look within the same mount or did you unmount and remount first? I 
remember there has been some issue with inode updates and unmounting, but 
I do not remember the details.

> (2)  If I missed a possibility to achieve regular atime behaviour,
> please document it in Documentation/filesystems/xfs.txt and in man 8
> mount.

Its either atime, relatime or noatime as mount option.

Martin 'Helios' Steigerwald - http://www.Lichtvoll.de
GPG: 03B0 0D6C 0040 0710 4AFA  B82F 991B EAAC A599 84C7

<Prev in Thread] Current Thread [Next in Thread>