xfs
[Top] [All Lists]

XFS ignores all atime related mount options, noatime is always in effect

To: SGI Project XFS mailing list <xfs@xxxxxxxxxxx>
Subject: XFS ignores all atime related mount options, noatime is always in effect, documentation misses this information
From: Roland Eggner <edvx1@xxxxxxxxxxxxxxxxxx>
Date: Thu, 18 Dec 2008 19:15:13 +0100
Reply-to: "Roland Eggner" <edvx1@xxxxxxxxxxxxxxxxxx>
User-agent: KMail/1.9.6
On my linux box I tried to achieve regular atime behaviour, tried mount with
no atime related option at all, tried mount options atime, sync,
osyncisosync, .. XFS on plain partitions, on loop devices .. I tried another
kernel (sidux image with kernel 2.6.25-9) ..

My result:
It seems impossible to switch off "noatime" mount option.
atime updates happen only in core, never on disk unless coinciding with other
inode modifications, regardless of specified mount options.

$  uname -a
Linux roland 2.6.23.12roland2 #2 Tue Apr 15 17:10:52 CEST 2008 i686 GNU/Linux

$  zgrep XFS /proc/config.gz
CONFIG_XFS_FS=m
# CONFIG_XFS_QUOTA is not set
CONFIG_XFS_SECURITY=y
CONFIG_XFS_POSIX_ACL=y
CONFIG_XFS_RT=y
# CONFIG_VXFS_FS is not set

In mailing list archive I found
http://oss.sgi.com/archives/xfs/2007-10/msg00168.html
It seems, that 3 years ago an unconditional noatime enforcement has been
introduced.

(1)  If this is true, please update documentation accordingly.
Users, who need a filesystem with regular atime behaviour, will no more waste
their time to try XFS, when in fact it is unusable for their particular
requirements.

(2)  If I missed a possibility to achieve regular atime behaviour, please
document it in Documentation/filesystems/xfs.txt and in man 8 mount.

Thanks!

-- 
Roland Eggner

<Prev in Thread] Current Thread [Next in Thread>