xfs
[Top] [All Lists]

Re: [TuxOnIce-devel] hangs with MTRR_SANITIZER? - solved

To: tuxonice-devel@xxxxxxxxxxxxxxxxxx
Subject: Re: [TuxOnIce-devel] hangs with MTRR_SANITIZER? - solved
From: Martin Steigerwald <ms@xxxxxxxxx>
Date: Mon, 8 Dec 2008 09:40:28 +0100
Cc: Martin Steigerwald <Martin@xxxxxxxxxxxx>, xfs@xxxxxxxxxxx, linux-kernel@xxxxxxxxxxxxxxx
In-reply-to: <200811300002.45669.Martin@xxxxxxxxxxxx>
Organization: team(ix) GmbH
References: <200811252244.14718.Martin@xxxxxxxxxxxx> <200811290824.38750.Martin@xxxxxxxxxxxx> <200811300002.45669.Martin@xxxxxxxxxxxx> (sfid-20081130_000254_807842_E480F4DF)
User-agent: KMail/1.9.9
Am Sonntag, 30. November 2008 schrieb Martin Steigerwald:
> Am Samstag 29 November 2008 schrieb Martin Steigerwald:
> > Hi!
> >
> > CC'd to linux-kernel mailinglist, as that might be something that goes
> > beyond any possible TuxOnIce or XFS issues. I know I am using TuxOnIce
> > which is not part of the mainline kernel. And I am even using an
> > inofficial patch - which I will use again unchanged for the non
> > MTRR_SANITIZER kernel, in order to know whether its the MTRR_SANITIZER
> > thing. And anyway before knowing whether it might be MTRR_SANITIZER
> > related I need to run the non MTRR_SANITIZER kernel for at least a week
> > and have quite some hibernate cycles. If someone else had issues with
> > MTRR_SANITIZER I would like to hear about it. Also if someone thinks I
> > am completely off track on trying to track this down I appreciate a
> > hint.
>
> Ok, its not MTRR_SANITIZER. It hung again on hibernate, again before any
> serious hibernating work has started. I will add debug output to my
> pre-hibernate script as it might hang already in there, maybe while
> disabling the network. I want to know whether it hangs before calling the
> hibernate script or after it. I think I will go for the latest official
> hibernate patch instead of using the inofficial one, although I am not
> convinced that it makes much of a difference. Lets see.
>
> The syncs I added to my pre-hibernate seemed to help. KDE configuration is
> intact. As a safeguard I rsync ~/.kde to a backup directory before
> hibernating anyway.

Okay... thats solved now.

Conclusions:

1) There was no XFS problem as the sync I added at the beginning of my pre 
hibernate script did avoid the truncated files the one time I still had the 
hang. Thus those appear to have been IO in flight.

2) Its not MTRR_SANITIZER as explained above nor any other mainline problem.

3) Instead problems gone, when I replaced the inofficial TuxOnIce rc7a for 
2.6.26 to 2.6.27 forward port patch I used[1] with the official but still not 
officially released current tuxonice for 2.6.27 patch[2].

So sorry for the noise. I just learned to prefer official upstream patches. 
Whether they'd be officially released or not. Can ask whether they appear to 
be stable before trying one. ;)

[1] 
http://lists.tuxonice.net/pipermail/tuxonice-devel/2008-November/000357.html

[2] http://www.tuxonice.net/downloads/all/current-tuxonice-2.6.27.patch.bz2

Ciao,
-- 
Martin Steigerwald - team(ix) GmbH - http://www.teamix.de
gpg: 19E3 8D42 896F D004 08AC A0CA 1E10 C593 0399 AE90

Attachment: signature.asc
Description: This is a digitally signed message part.

<Prev in Thread] Current Thread [Next in Thread>
  • Re: [TuxOnIce-devel] hangs with MTRR_SANITIZER? - solved, Martin Steigerwald <=