[Top] [All Lists]

Re: [patch 20/22] move vn_iowait / vn_iowake into xfs_aops.c

To: Christoph Hellwig <hch@xxxxxxxxxxxxx>, xfs@xxxxxxxxxxx
Subject: Re: [patch 20/22] move vn_iowait / vn_iowake into xfs_aops.c
From: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date: Wed, 3 Dec 2008 05:58:31 -0500
In-reply-to: <20081203031719.GQ18236@disturbed>
References: <20081202160430.775774000@xxxxxxxxxxxxxxxxxxxxxx> <20081202160652.542003000@xxxxxxxxxxxxxxxxxxxxxx> <20081203031719.GQ18236@disturbed>
User-agent: Mutt/1.5.18 (2008-05-17)
On Wed, Dec 03, 2008 at 02:17:19PM +1100, Dave Chinner wrote:
> On Tue, Dec 02, 2008 at 11:04:50AM -0500, Christoph Hellwig wrote:
> > The whole machinery to wait on I/O completion is related to the I/O path
> > and should be there instead of in xfs_vnode.c.  Also give the functions
> > more descriptive names.
> I'm not sure that "xfs_ioend_..." is the best name - it looks
> slightly weird in some of the callers' contexts. Just dropping the
> "end" out of the names makes the code read much better (i.e.
> xfs_io_wait() and xfs_io_wake()). Not particularly important,
> though, and everything else looks good.

xfs_ioend_* wasn't my first choice either.  I first did
xfs_iowait/xfs_iowake, but that clashes with the buffercache.  And
having names just different by an underscore doesn't seem good either.

Any other suggestions?

<Prev in Thread] Current Thread [Next in Thread>