[Top] [All Lists]

Re: [patch 20/22] move vn_iowait / vn_iowake into xfs_aops.c

To: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Subject: Re: [patch 20/22] move vn_iowait / vn_iowake into xfs_aops.c
From: Dave Chinner <david@xxxxxxxxxxxxx>
Date: Wed, 3 Dec 2008 14:17:19 +1100
Cc: xfs@xxxxxxxxxxx
In-reply-to: <20081202160652.542003000@bombadil.infradead.org>
Mail-followup-to: Christoph Hellwig <hch@xxxxxxxxxxxxx>, xfs@xxxxxxxxxxx
References: <20081202160430.775774000@bombadil.infradead.org> <20081202160652.542003000@bombadil.infradead.org>
User-agent: Mutt/1.5.18 (2008-05-17)
On Tue, Dec 02, 2008 at 11:04:50AM -0500, Christoph Hellwig wrote:
> The whole machinery to wait on I/O completion is related to the I/O path
> and should be there instead of in xfs_vnode.c.  Also give the functions
> more descriptive names.

I'm not sure that "xfs_ioend_..." is the best name - it looks
slightly weird in some of the callers' contexts. Just dropping the
"end" out of the names makes the code read much better (i.e.
xfs_io_wait() and xfs_io_wake()). Not particularly important,
though, and everything else looks good.

Reviewed-by: Dave Chinner <david@xxxxxxxxxxxxx>

Dave Chinner

<Prev in Thread] Current Thread [Next in Thread>