[Top] [All Lists]

Re: Bad day with xfsrestore, what went wrong?

To: mlueck@xxxxxxxxxxxxxxxxxxxx
Subject: Re: Bad day with xfsrestore, what went wrong?
From: Bill Kendall <wkendall@xxxxxxx>
Date: Mon, 27 Oct 2008 17:23:49 -0500
Cc: linux-xfs@xxxxxxxxxxx
In-reply-to: <ge38k5$qf$1@xxxxxxxxxxxxx>
References: <gde1k2$gkp$1@xxxxxxxxxxxxx> <ge38k5$qf$1@xxxxxxxxxxxxx>
User-agent: Thunderbird (X11/20080502)
Michael Lueck wrote:
No suggestions / possible answers anyone for my question...

Michael Lueck wrote:

I hope this is the NNTP equiv of the email list found on this web page:

I have been using XFS with Debian for a number of years with great success. Today, xfsrestore really threw me a curve ball. I am wondering what went wrong.

I had wanted to restore from an old backup some directories that I discovered I had need of. I used the following syntax to get the restore started:

xfsrestore -J -E -f /mnt/ext_backup/ldslnx01/20061220/data -s shares/data -i -v verbose /srv

I selected some directories to restore through the interactive interface, then allowed it to restore the specified files.

What it ended up doing, HOWEVER, was to restore every file present in that old backup that was no longer on disk!

Thus, what went wrong?


Hi Michael,

I tried to reproduce this using the command line you supplied, but
everything worked as expected for me. Perhaps try it without the -i
(so that only subtrees given with -s are restored), just to rule out
the possibility that you inadvertently added all files to the restore


<Prev in Thread] Current Thread [Next in Thread>