xfs
[Top] [All Lists]

Re: Partition seems to have been zero:ed. For no reason.

To: "Johan Stenehall" <stenehall@xxxxxxxxx>, xfs@xxxxxxxxxxx
Subject: Re: Partition seems to have been zero:ed. For no reason.
From: "Johan Stenehall" <stenehall@xxxxxxxxx>
Date: Wed, 22 Oct 2008 08:22:36 +0200
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:received:received:message-id:date:from:to :subject:in-reply-to:mime-version:content-type:references; bh=57URlH6jzgQJ6vNonfouxsFH7Y5DVESZ/sjLCYfm2DI=; b=WmDh/0bi+jAbWdAcDqZylrbkoxlFQmspTg5wUNZxJtU0QbaQmr9w1wf99GYMRj9bDf dMpGJIFvClYvSgfDZQe6pmBRPFVkrteiFY1j9xVLb3lbU0QsF87U3hBp83f/SzfQNjYb /BsA5K0UDGnOAOTLxs3RDeA2TZc4US9UE30qU=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=message-id:date:from:to:subject:in-reply-to:mime-version :content-type:references; b=qPuN4QNVTkLOPVOPVpYVP7ejxNp2iJ1r+FwDoc69KHKHCIHeWzrLJp4P5+uRRcyvHT 3MjKgCGWSkCQvphuzw6FBcKGDbD2mdhAXPzoH0xlTjB6D+yEME6dDjbBVb7fnRQOG8vW 8cgfL6dgWVnt22zqh5q9F8l/ItX+mhOs6cjvE=
In-reply-to: <20081021212158.GN25906@disturbed>
References: <934a72850810211111g20accf8ey74f0bfb8ecf38532@xxxxxxxxxxxxxx> <20081021212158.GN25906@disturbed>
No LVM and since I don't know what MD are I guess not. It was a plain
parition created with mkfs.xfs and fdisk.
And no, no backups of the current partition, don't have enough diskspace
anywere do to a hd backup and dvd's take to long time to burn. But nothing
that importent was destroyed, it'l just take time to flac the cds again :).

The same problem with UUID's stoping to work happend a year ago when
upgrading kernal, so that is nothing new with ubuntu. That time I didn't
lose any information.

Thanks for the replay!

// Johan


2008/10/21 Dave Chinner <david@xxxxxxxxxxxxx>

> On Tue, Oct 21, 2008 at 08:11:50PM +0200, Johan Stenehall wrote:
> > After a kernal upgrade My UUIDs in /etc/fstab stoped working so I changed
> > them to /dev/sd* When rebooting again /dev/sdb2 didn't want to mount. I
> > tried to manualy mount it without success and tried to run a xfs_repair
> on
> > it. Got the following: http://pastebin.com/m44d3aa47
>
> Are you using LVM or MD? i.e. did a volume get re-assembled
> incorrectly and hence the XFS tools saw random fragments of a
> filesystem?
>
> > After that the partition still didn't want to mount. Had to overwrite the
> > inprogress flag "xfs_db> write inprogress 0", That aloud me to mount the
> > partition but it looked entirly empty.
> >
> > A very nice person, <sandeen_> (thank you), on xfs@freenode tried to
> help
> > me. However it seems like the entire disk, or part of it, have been
> zero:ed.
> >
> > Does anyone know if it's possible to recover from this? And if so how?
>
> Recovery is possible - it's called restoring from backups. You do have a
> backup, don't you?
>
> > Running Linux Ubuntu, 8.04 32-bit
> > uname -r
> > 2.6.24-21-generic
> > xfs_repair -V
> > xfs_repair version 2.9.4
>
> Hmmmmm - haven't we have these symptoms reported by a couple of
> Ubuntu users now? There's been a few ppl reporting such problems
> of late....
>
> Cheers,
>
> Dave.
> --
> Dave Chinner
> david@xxxxxxxxxxxxx
>


[[HTML alternate version deleted]]

<Prev in Thread] Current Thread [Next in Thread>