xfs
[Top] [All Lists]

Re: Partition seems to have been zero:ed. For no reason.

To: Johan Stenehall <stenehall@xxxxxxxxx>
Subject: Re: Partition seems to have been zero:ed. For no reason.
From: Dave Chinner <david@xxxxxxxxxxxxx>
Date: Wed, 22 Oct 2008 08:21:58 +1100
Cc: xfs@xxxxxxxxxxx
In-reply-to: <934a72850810211111g20accf8ey74f0bfb8ecf38532@xxxxxxxxxxxxxx>
Mail-followup-to: Johan Stenehall <stenehall@xxxxxxxxx>, xfs@xxxxxxxxxxx
References: <934a72850810211111g20accf8ey74f0bfb8ecf38532@xxxxxxxxxxxxxx>
User-agent: Mutt/1.5.18 (2008-05-17)
On Tue, Oct 21, 2008 at 08:11:50PM +0200, Johan Stenehall wrote:
> After a kernal upgrade My UUIDs in /etc/fstab stoped working so I changed
> them to /dev/sd* When rebooting again /dev/sdb2 didn't want to mount. I
> tried to manualy mount it without success and tried to run a xfs_repair on
> it. Got the following: http://pastebin.com/m44d3aa47

Are you using LVM or MD? i.e. did a volume get re-assembled
incorrectly and hence the XFS tools saw random fragments of a
filesystem?

> After that the partition still didn't want to mount. Had to overwrite the
> inprogress flag "xfs_db> write inprogress 0", That aloud me to mount the
> partition but it looked entirly empty.
> 
> A very nice person, <sandeen_> (thank you), on xfs@freenode tried to help
> me. However it seems like the entire disk, or part of it, have been zero:ed.
> 
> Does anyone know if it's possible to recover from this? And if so how?

Recovery is possible - it's called restoring from backups. You do have a
backup, don't you?

> Running Linux Ubuntu, 8.04 32-bit
> uname -r
> 2.6.24-21-generic
> xfs_repair -V
> xfs_repair version 2.9.4

Hmmmmm - haven't we have these symptoms reported by a couple of
Ubuntu users now? There's been a few ppl reporting such problems
of late....

Cheers,

Dave.
-- 
Dave Chinner
david@xxxxxxxxxxxxx

<Prev in Thread] Current Thread [Next in Thread>