xfs
[Top] [All Lists]

Partition seems to have been zero:ed. For no reason.

To: xfs@xxxxxxxxxxx
Subject: Partition seems to have been zero:ed. For no reason.
From: "Johan Stenehall" <stenehall@xxxxxxxxx>
Date: Tue, 21 Oct 2008 20:11:50 +0200
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:received:received:message-id:date:from:to :subject:mime-version:content-type; bh=SIokl7lOSOdjp3hknMl/2VHY9s17Tirq547CRIxDti8=; b=PzHMPVVusgC1WhLDe/f4hwr2jrMd7THHuJsuztQD/RbV6Qw7WTybsy9K99EVeI76PD 3E6uuaMcSpQ/Nm3PIHnrXL8r/l3UoqgcuOAXsfIDRqLEqzheFbcRE0hdK0vJzkMjm+LS Ql8cMtwbw5Kffot0agGSLbZbKsVgrCEYkqlhE=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=message-id:date:from:to:subject:mime-version:content-type; b=PvOPwLpgB9BM5+wX0hgmXCbazU6uU2m3VE37TMZFNGyFUL/N/vOfdBotra6BVCHHON 84OWzvbKtQSv6aPpyZJ6jI5kb8dq3g9hkrqBeKYzLme9jsDmGAkB5c+WleojZjrcMmTp KmX1qo5XBK7ptR4DIeXCvXaExBN0flnMJJxtU=
After a kernal upgrade My UUIDs in /etc/fstab stoped working so I changed
them to /dev/sd* When rebooting again /dev/sdb2 didn't want to mount. I
tried to manualy mount it without success and tried to run a xfs_repair on
it. Got the following: http://pastebin.com/m44d3aa47
After that the partition still didn't want to mount. Had to overwrite the
inprogress flag "xfs_db> write inprogress 0", That aloud me to mount the
partition but it looked entirly empty.

A very nice person, <sandeen_> (thank you), on xfs@freenode tried to help
me. However it seems like the entire disk, or part of it, have been zero:ed.

Does anyone know if it's possible to recover from this? And if so how?

Running Linux Ubuntu, 8.04 32-bit
uname -r
2.6.24-21-generic
xfs_repair -V
xfs_repair version 2.9.4

Hope this information is sufficent. Thanks in advance for any answers

// Johan (please forgive my english)


[[HTML alternate version deleted]]

<Prev in Thread] Current Thread [Next in Thread>