xfs
[Top] [All Lists]

RE: Stale XFS mount for Kernel 2.6.25.14

To: Dave Chinner <david@xxxxxxxxxxxxx>, v9fs-developer@xxxxxxxxxxxxxxxxxxxxx
Subject: RE: Stale XFS mount for Kernel 2.6.25.14
From: "Ngo, Andrew" <andrew.ngo@xxxxxxxx>
Date: Mon, 13 Oct 2008 22:04:27 -0400
Cc: xfs@xxxxxxxxxxx, "Johnson, Je" <je.johnson@xxxxxxxx>, "Ngo, Andrew" <andrew.ngo@xxxxxxxx>
In-reply-to: <8604545CB7815D419F5FF108D3E434BA3BD628@xxxxxxxxxxxxxxxxxxxxx>
References: <8604545CB7815D419F5FF108D3E434BA3BD626@xxxxxxxxxxxxxxxxxxxxx> <20081013035939.GB10716@disturbed> <8604545CB7815D419F5FF108D3E434BA3BD628@xxxxxxxxxxxxxxxxxxxxx>
Thread-index: AcktJQhmcWjT+CMtS2+hWv8Ow7jKFAAAtlTQAB2XZQA=
Thread-topic: Stale XFS mount for Kernel 2.6.25.14
Dave,

Do you know of a solution to this problem?  Currently this is a major
impact for my system.  Thanks in advance.

Andy Ngo

-----Original Message-----
From: Ngo, Andrew 
Sent: Monday, October 13, 2008 8:07 AM
To: 'Dave Chinner'
Cc: xfs@xxxxxxxxxxx; Johnson, Je; Ngo, Andrew
Subject: RE: Stale XFS mount for Kernel 2.6.25.14

No.  There is no oops in the /var/log/messages when the mount command
hangs.

Andy Ngo 

-----Original Message-----
From: Dave Chinner [mailto:david@xxxxxxxxxxxxx]
Sent: Monday, October 13, 2008 12:00 AM
To: Ngo, Andrew
Cc: xfs@xxxxxxxxxxx; Johnson, Je
Subject: Re: Stale XFS mount for Kernel 2.6.25.14

On Sun, Oct 12, 2008 at 10:10:54PM -0400, Ngo, Andrew wrote:
> Hi,
>  
> This is my first attempt to report a stale mount problem.  If this is 
> not the relevant mail list, please let me know.  I suspect that my 
> problem is xfs related, thus I select this mailing list.
>  
> I have a system that recently upgraded it's kernel to 2.6.25.14.  The 
> system's previous kernel was 2.6.18.-8.el5.  With the previous kernel,

> I have no problem with executing the following commands when the 
> system is in operation.  Note that the /mnt/mountpoint is mounted on a

> XFS file system.
>  
> mount -o rw,remount /mnt/mountpoint
> mount -o ro,remount /mnt/mountpoint
>  
> With kernel 2.6.25.14, however, the mount command may be hang when 
> changing from rw to ro.  When this happen, system is very sluggish.

That's because the remount,ro is actually flushing all the dirty data to
disk in 2.6.25. There is also a check to catch when the remount,ro fails
to clean everything that is dirty - that's probably what is triggering.
Do you have an oops in the dmesg log when mount hangs?

Cheers,

Dave.
--
Dave Chinner
david@xxxxxxxxxxxxx


<Prev in Thread] Current Thread [Next in Thread>