xfs
[Top] [All Lists]

Re: sanitize xlog_in_core_t definition

To: Christoph Hellwig <hch@xxxxxx>
Subject: Re: sanitize xlog_in_core_t definition
From: Dave Chinner <david@xxxxxxxxxxxxx>
Date: Tue, 16 Sep 2008 15:11:18 +1000
Cc: xfs@xxxxxxxxxxx
In-reply-to: <20080915002348.GA11469@xxxxxx>
Mail-followup-to: Christoph Hellwig <hch@xxxxxx>, xfs@xxxxxxxxxxx
References: <20080915002348.GA11469@xxxxxx>
User-agent: Mutt/1.5.18 (2008-05-17)
On Mon, Sep 15, 2008 at 02:23:48AM +0200, Christoph Hellwig wrote:
> Move all fields from xlog_iclog_fields_t into xlog_in_core_t instead of having
> them in a substructure and the using #defines to make it look like they were
> directly in xlog_in_core_t.  Also document that xlog_in_core_2_t is grossly
> misnamed, and make all references to it typesafe.

Looks ok.

Cheers,

Dave.
-- 
Dave Chinner
david@xxxxxxxxxxxxx

<Prev in Thread] Current Thread [Next in Thread>