xfs
[Top] [All Lists]

Re: REVIEW: Remove convert_extent function in xfs_repair

To: Barry Naujok <bnaujok@xxxxxxx>
Subject: Re: REVIEW: Remove convert_extent function in xfs_repair
From: Christoph Hellwig <hch@xxxxxxxxxxxxx>
Date: Tue, 26 Aug 2008 15:15:47 -0400
Cc: "xfs@xxxxxxxxxxx" <xfs@xxxxxxxxxxx>
In-reply-to: <op.ugg16sju3jf8g2@xxxxxxxxxxxxxxxxxxxxxxxxxxxx>
References: <op.ugg16sju3jf8g2@xxxxxxxxxxxxxxxxxxxxxxxxxxxx>
Sender: xfs-bounce@xxxxxxxxxxx
User-agent: Mutt/1.5.18 (2008-05-17)
On Tue, Aug 26, 2008 at 12:21:54PM +1000, Barry Naujok wrote:
> It seems convert_extent is not that useful, so remove it and call
> libxfs_bmbt_disk_get_all() directly and use the xfs_bmbt_irec_t
> structure directly.

Yes, the new code is much more readable.  The patch looks good to m.


<Prev in Thread] Current Thread [Next in Thread>