xfs
[Top] [All Lists]

Re: XFS noikeep remount in 2.6.27-rc1-next-20080730

To: Jasper Bryant-Greene <jasper@xxxxxxxxxxxx>, linux-kernel@xxxxxxxxxxxxxxx, xfs@xxxxxxxxxxx, util-linux-ng@xxxxxxxxxxxxxxx
Subject: Re: XFS noikeep remount in 2.6.27-rc1-next-20080730
From: Christoph Hellwig <hch@xxxxxx>
Date: Fri, 1 Aug 2008 21:31:33 +0200
In-reply-to: <20080801073033.GF6201@disturbed>
References: <1217553598.3860.16.camel@xxxxxxxxxxxxxxxxx> <20080801073033.GF6201@disturbed>
Sender: xfs-bounce@xxxxxxxxxxx
User-agent: Mutt/1.3.28i
On Fri, Aug 01, 2008 at 05:30:33PM +1000, Dave Chinner wrote:
> On Fri, Aug 01, 2008 at 01:19:58PM +1200, Jasper Bryant-Greene wrote:
> > I mount a bunch of XFS filesystems with "noikeep,attr2,noatime", and a
> > couple also with "ro".
> > 
> > Sometimes I want to remount one of the "ro" ones "rw", to make changes.
> > This doesn't work anymore in 2.6.27-rc1-next-20080730. The last kernel I
> > tried which it worked in was 2.6.26 release.
> > 
> > luna ~ # mount -o remount,rw /usr
> > mount: /usr not mounted already, or bad option
> > 
> > luna ~ # dmesg | tail -n 1
> > [18702.291344] XFS: mount option "noikeep" not supported for remount
> > 
> > Is this intended behaviour?
> 
> Side effect of this commit:
> 
> http://oss.sgi.com/cgi-bin/gitweb.cgi?p=xfs/xfs-2.6.git;a=commit;h=0327f9d799ebb96f67c80dd732b1fdb09527365e
> 
> Christoph?

I'ts most likely a fallout, but I wonder why.  To get this behaviour
moutn would have to add all the options it finds in /proc/self/mounts
to the command line.

Added the util-linux-ng list to shed some light on this, but I suspect
I'll have to change xfs_fs_remount to check if the option passed in
is identical to the one we already have and only reject it when it
changes due to this mount(1) dumbness.


<Prev in Thread] Current Thread [Next in Thread>