xfs
[Top] [All Lists]

Re: XFS noikeep remount in 2.6.27-rc1-next-20080730

To: Jasper Bryant-Greene <jasper@xxxxxxxxxxxx>
Subject: Re: XFS noikeep remount in 2.6.27-rc1-next-20080730
From: Dave Chinner <david@xxxxxxxxxxxxx>
Date: Fri, 1 Aug 2008 17:30:33 +1000
Cc: linux-kernel@xxxxxxxxxxxxxxx, xfs@xxxxxxxxxxx, hch@xxxxxx
In-reply-to: <1217553598.3860.16.camel@xxxxxxxxxxxxxxxxx>
Mail-followup-to: Jasper Bryant-Greene <jasper@xxxxxxxxxxxx>, linux-kernel@xxxxxxxxxxxxxxx, xfs@xxxxxxxxxxx, hch@xxxxxx
References: <1217553598.3860.16.camel@xxxxxxxxxxxxxxxxx>
Sender: xfs-bounce@xxxxxxxxxxx
User-agent: Mutt/1.5.18 (2008-05-17)
[cc'd xfs@xxxxxxxxxxx]

On Fri, Aug 01, 2008 at 01:19:58PM +1200, Jasper Bryant-Greene wrote:
> I mount a bunch of XFS filesystems with "noikeep,attr2,noatime", and a
> couple also with "ro".
> 
> Sometimes I want to remount one of the "ro" ones "rw", to make changes.
> This doesn't work anymore in 2.6.27-rc1-next-20080730. The last kernel I
> tried which it worked in was 2.6.26 release.
> 
> luna ~ # mount -o remount,rw /usr
> mount: /usr not mounted already, or bad option
> 
> luna ~ # dmesg | tail -n 1
> [18702.291344] XFS: mount option "noikeep" not supported for remount
> 
> Is this intended behaviour?

Side effect of this commit:

http://oss.sgi.com/cgi-bin/gitweb.cgi?p=xfs/xfs-2.6.git;a=commit;h=0327f9d799ebb96f67c80dd732b1fdb09527365e

Christoph?

FWIW, noikeep is the default, so you don't need to specify it.

Cheers,

Dave.
-- 
Dave Chinner
david@xxxxxxxxxxxxx


<Prev in Thread] Current Thread [Next in Thread>