[Top] [All Lists]

Re: [PATCH 07/15] refactor xfs_btree_readahead

To: Christoph Hellwig <hch@xxxxxx>
Subject: Re: [PATCH 07/15] refactor xfs_btree_readahead
From: Dave Chinner <david@xxxxxxxxxxxxx>
Date: Wed, 30 Jul 2008 17:35:22 +1000
Cc: xfs@xxxxxxxxxxx
In-reply-to: <20080728153959.GA29132@xxxxxx>
Mail-followup-to: Christoph Hellwig <hch@xxxxxx>, xfs@xxxxxxxxxxx
References: <20080723200859.GH7401@xxxxxx> <20080724233655.GH15438@disturbed> <20080728153959.GA29132@xxxxxx>
Sender: xfs-bounce@xxxxxxxxxxx
User-agent: Mutt/1.5.18 (2008-05-17)
On Mon, Jul 28, 2008 at 05:39:59PM +0200, Christoph Hellwig wrote:
> On Fri, Jul 25, 2008 at 09:36:55AM +1000, Dave Chinner wrote:
> > I've been wondering if this is the best naming convention -
> > appending a single s or l to indicate short or long btree ops.
> > Perhaps this would be better as xfs_btree_readahead_short() and
> > xfs_btree_readahead_long(), esp. as we dropped the 'core' from
> > the caller to make it xfs_btree_readahead().
> I've renamedthe helpers to xfs_btree_readahead_lblock /
> xfs_btree_readahead_slblock to match the naming for the other short /
> long block helpers.

Ok, that sounds reasonable.


Dave Chinner

<Prev in Thread] Current Thread [Next in Thread>