[Top] [All Lists]

Re: [PATCH 07/15] refactor xfs_btree_readahead

To: Christoph Hellwig <hch@xxxxxx>, xfs@xxxxxxxxxxx
Subject: Re: [PATCH 07/15] refactor xfs_btree_readahead
From: Christoph Hellwig <hch@xxxxxx>
Date: Mon, 28 Jul 2008 17:39:59 +0200
In-reply-to: <20080724233655.GH15438@disturbed>
References: <20080723200859.GH7401@xxxxxx> <20080724233655.GH15438@disturbed>
Sender: xfs-bounce@xxxxxxxxxxx
User-agent: Mutt/1.3.28i
On Fri, Jul 25, 2008 at 09:36:55AM +1000, Dave Chinner wrote:
> I've been wondering if this is the best naming convention -
> appending a single s or l to indicate short or long btree ops.
> Perhaps this would be better as xfs_btree_readahead_short() and
> xfs_btree_readahead_long(), esp. as we dropped the 'core' from
> the caller to make it xfs_btree_readahead().

I've renamedthe helpers to xfs_btree_readahead_lblock /
xfs_btree_readahead_slblock to match the naming for the other short /
long block helpers.

<Prev in Thread] Current Thread [Next in Thread>