xfs
[Top] [All Lists]

Re: xfs_repair trouble

To: xfs@xxxxxxxxxxx
Subject: Re: xfs_repair trouble
From: "Simon Jakesch" <simon.jakesch@xxxxxxxxx>
Date: Thu, 19 Jun 2008 22:45:50 -0400
Cc: "Barry Naujok" <bnaujok@xxxxxxx>
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:received:received:message-id:date:from:to :subject:cc:in-reply-to:mime-version:content-type :content-transfer-encoding:content-disposition:references; bh=QP/G6wuHbEUvmfU1TjxRan2vLd3g1OQ2gif53nD57XY=; b=fvvNbILuYxWrnpJEzkf9BP3zynREmVonxEcRWMp3He6xms3ZiUKdQ3FMdatgbSoelI 7jZL0dKwFDvjg0aG+cH99c/J7DdT5F8vQf74hPI8zl62srrLFjRalbklvwW17wX1oS1M oAW1B1k659FvdbhuNcDRmObUV64L9uilH4lRU=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=message-id:date:from:to:subject:cc:in-reply-to:mime-version :content-type:content-transfer-encoding:content-disposition :references; b=VUr8aHIhaSNEg8Jv2+rdGGeAbWz/12Hccc3J4czs+9G7K/Y8fFZWaJeyb1b9TajvDF 2g1zIJfovDU+b4DWC9HAZvmbaWu6VH678s6/of+SRQ0cQe5o/Yyuub1b6EVW7UrFBWOf 5oVLdTosOncyb6mHTaTkcOkk5AIJbvs4vxt7Q=
In-reply-to: <op.uctrkqf73jf8g2@xxxxxxxxxxxxxxxxxxxxxxxxxxxx>
References: <dd599fe00806140943g13c790dfo9b3a84d7f9841641@xxxxxxxxxxxxxx> <op.uctrkqf73jf8g2@xxxxxxxxxxxxxxxxxxxxxxxxxxxx>
Sender: xfs-bounce@xxxxxxxxxxx
Running xfs_metadump.sh will give me output below. Does all this mean
it's best to think about alternatives to fixing/recovering these
files?

root@redlace:~/xfsprogs-trunk/xfs-cmds/xfsprogs/db# ./xfs_metadump.sh
-g /dev/evms/monster_evms monster.dump
Copied 320 of 112448 inodes (0 of 0 AGs)                   xfs_db:
metadump.c:465: generate_obfuscated_name: Assertion
`libxfs_da_hashname(newname, namelen) == hash' failed.
./xfs_metadump.sh: line 31: 17542 Aborted
xfs_db$DBOPTS -i -p xfs_metadump -c "metadump$OPTS $2" $1


On Mon, Jun 16, 2008 at 12:47 AM, Barry Naujok <bnaujok@xxxxxxx> wrote:
> On Sun, 15 Jun 2008 02:43:12 +1000, Simon <simonjj@xxxxxxxxx> wrote:
>
>> Hello all,
>>
>>
>> I have a corrupted xfs filesystem on top of a RAID 5 (1TB in size).
>> The RAID is still fully intact but the filesystem was damaged. When
>> trying to repair the filesystem xfs_repair fails. I have tried various
>> versions of xfs_repair, the latest stable (2.9.8) and the latest trunk
>> (from CVS). I'd love to investigate and/or fix the issue further but I
>> am a bit confused about some of my xfs_repair runs (both done with
>> trunk).
>> Could someone shed some light on where the problem could be, I'd be
>> happy to continue digging if I would only know where roughly
>
> Are you able to generate an xfs_metadump? If you can make that available,
> I should be able to find out the problem pretty easily.
>
> Regards,
> Barry.
>


<Prev in Thread] Current Thread [Next in Thread>