xfs
[Top] [All Lists]

Lost Superblock and need help recovering

To: xfs@xxxxxxxxxxx
Subject: Lost Superblock and need help recovering
From: Javier Gomez <gomez@xxxxxxxxxxxxxxxx>
Date: Sun, 25 May 2008 22:40:31 -0400
Sender: xfs-bounce@xxxxxxxxxxx
User-agent: Thunderbird 2.0.0.14 (Windows/20080421)


We are currently running a few Coraid AoE devices which we have formated using Raid-5 and XFS filesystem. The devices were shutdown abruptly causing what looks like a some data issues. We are running a Redhat 5 head unit connected to the disk array. When the devices came back up we were unable to remount them. Based on the tools to check the device we got the log information that the Superblock does not exist nor does the secondary. We have two devices, each with 13 TB of disk space each and both with what seems like the same issue. These devices were used as a backup storage device, so they are the backup. But this historical information is very critical to us. We attempted to run the "xfs_repair -nv /dev/etherd/e4.1p1" command to see if found the potential issues ( xfs_repair version 2.9.8 ). It came back with the comments noted below. Does any one have any suggestions for pulling this information off the drive and / or correcting this issue? What other tools should I run to get more information? Thanks for any support or suggestions you can provide.


> xfs_repair -nv /dev/etherd/e4.1p1
---------------------------------------------------------------
Phase 1 - find and verify superblock...
error reading superblock 4 -- seek to offset 1219003957248 failed
couldn't verify primary superblock - bad magic number !!!

attempting to find secondary superblock...
................................................................................................
......................................................
..................
..................
............Sorry, could not find valid secondary superblock
Exiting now.
---------------------------------------------------------------


<Prev in Thread] Current Thread [Next in Thread>